CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CD-adapco

TCL/TK

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 18, 2005, 08:27
Default TCL/TK
  #1
Tom
Guest
 
Posts: n/a
Hi there,

I need your help and advise: when using a tcl/tk scriptfile my IBM workstaion dramatically slows down. It takes 2-3 seconds after each mouse-click to see the graphics reacting. I have same trouble with the proam-panel. I assume it is also written in tcl/tk.

Anybody out there who can help?

thanks a lot.

Tom
  Reply With Quote

Old   July 19, 2005, 05:05
Default Re: TCL/TK
  #2
Alex
Guest
 
Posts: n/a
Just a comment: Same problem on x86_64 Linux, proam tcl/tk menues are extremely slow.

Star support could not reproduce the problem, they suggest:

I'm not able to reproduce your problem on our machines. It seems to be a system-specific problem. Please have a look at the way the license for proam is checked out. Is the proam-executable located on our local machine or on another machine? This might be reasons why proam is so slow on your local machine. If your local network-speed is slow.

Best Regards

Alex
  Reply With Quote

Old   July 19, 2005, 06:02
Default Re: TCL/TK
  #3
Volker
Guest
 
Posts: n/a
Regarding the slow menu on Linux 64bit: If you have the possibility, use the 32bit version of proam. That should make the menu behave normally.

Volker
  Reply With Quote

Old   July 19, 2005, 06:45
Default Re: TCL/TK
  #4
Tom
Guest
 
Posts: n/a
thanks a lot for your suggestions - but in my case proam runs locally (so no networking bottle neck) and it is the same behaviour when executing a tcl-script file in prostar/proam from the users tool.

any other ideas?
  Reply With Quote

Old   July 24, 2005, 07:27
Default Re: TCL/TK
  #5
Hubert Janocha
Guest
 
Posts: n/a
I am sorry to tell you, that there is no remidy. At the adapco support this problem for AIX 5.1 is known. Someone at the support asked me (!) if I have this problem an AIX 5.1 !!!

I think the problem belongs to IBM. I have other software which is not as slow as the ProAM-panel, but much slower as on AIX 4.3 and on Linux x86.

When I start the old v3150A on AIX 5.1 there is no problem ProAM-Pannel-speed. Funny thing.

  Reply With Quote

Old   July 25, 2005, 07:39
Default Re: TCL/TK
  #6
steve
Guest
 
Posts: n/a
The problem with TCK/TK being slow seems to be related to using 64bit versions. The reason 3.150A runs fast is most likely that its still a 32 bit version.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 03:11.