CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CD-adapco

problems when running subroutine

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 2, 2005, 04:04
Default problems when running subroutine
  #1
limingtiger
Guest
 
Posts: n/a
when i try to run an example with following programm, the warning message haapened in the end. how can i deal with it. thank you!

ctab,1,fluid,2, ctname,1,water vc3d,0,1,10,0,1,10,0,2,20 cset all $ cplo rdef,1,inle bzon,1,, $bset,add,bran,1,mxb !SCRN, 0 3.9559 6.6254 !SCRN, 0 9.5011 6.6431 !SCRN, 0 9.5011 1.0424 !SCRN, 0 3.7086 1.0424 !SCRN, 0 4.0088 6.6078 view,reverse $repl rdef,2,outl bzon,2,, $bset,add,bran,37,mxb !SCRN, 0 3.9205 9.9293 !SCRN, 0 3.9205 4.9470 !SCRN, 0 9.6247 5.0707 !SCRN, 0 9.4835 9.9293 !SCRN, 0 3.8852 9.9293 cdisp,on,breg cplot pmat,1,fluid,AIR dens,constant,1.205 lvis,constant,1.81e-05 spec,constant,1006 cond,constant,0.02637 pmat,1,fluid turb,ke,1,stan lowre,off coke,0.09,1.44,1.92,1.44,-0.33,0.419,1,1.219,0.9,,, pmat,1,fluid moni,1 pres,1.e+05,1 tdatum,273 system ufiles usub,write $BCDEFI time,single,nodefa,const,5 ,rate lstep,1,100 ,const,5 ,n,0,1 cpost,t,t,t,f,t,t,f,f,f,f,f,f,f,f iter,100 lstep,1,100 ,const,5,n,0,1 save,star1.mdl geom,star1.geom,1,binary,check,serial, prob,star1.prob,binary geom,star1.geom,1,bina,check prob,star1.prob,bina close,star1.drp

I actived the parameters U=10, V=10, Z=10 in subrutine BCDEFI. But when I ran the the program, it exited with the following warnings:

linking single precision sequential executable "star.exe" with user subroutines… WARNING:Command execution error. Please check screen output for details Starin.f compile error. Exiting starlink. C:/Program Files/CD-adapco/STAR-CD_V3150A/wingnu/bin/basename.exe: too few arguments Try C:/Program Files/CD-adapco/STAR-CD_V3150A/wingnu/bin/basename.exe:--help' for more information. C:/Program Files/CD-adapco/STAR-CD_V3150A/ bin/starlink[725]:[:Absoft 62: unexpected operator/operand C:/Program Files/CD-adapco/STAR-CD_V3150A/ bin/starlink[725]:[:Absoft 70: unexpected operator/operand F77:error switch '_f' is ambiguous D:\sartcd>pause Press any key to continue…

  Reply With Quote

Old   November 2, 2005, 06:10
Default Re: problems when running subroutine
  #2
4xF
Guest
 
Posts: n/a
Do you have by chance the ABSOFT compiler installed on your system? If not, please get it and/or install it correctly.
  Reply With Quote

Old   November 2, 2005, 20:29
Default Re: problems when running subroutine
  #3
limingtiger
Guest
 
Posts: n/a
I installed the compact fortran, is this software proper for the star-cd?
  Reply With Quote

Old   November 3, 2005, 03:01
Default Re: problems when running subroutine
  #4
Tom
Guest
 
Posts: n/a
no, not at all

you have to use absoft

maybe there is a way to use the compact fortran compiler, but i would never go in this direction.

A general recommendation for YOU:

YOU should read the installation manual of STAR-CD after this you should have a look at the tutorials in parallel you should have a look at the manuals

this would be 'the' normal way to get familiar with a software

  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird problems running unsteady braennstroem OpenFOAM Running, Solving & CFD 5 June 8, 2011 20:38
Problems on CFDRC-ACE User-Subroutine Xiaopeng Chen Main CFD Forum 0 November 30, 2006 22:05
Problems on running cfx in parallel Nan CFX 1 March 29, 2006 04:10
Help???Subroutine running erro? blackhole CD-adapco 5 December 17, 2004 08:12
Help? tut2.4 subroutine running error? zhichun97 CD-adapco 2 December 2, 2004 15:22


All times are GMT -4. The time now is 00:11.