CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CD-adapco

Increase maxsc2

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 5, 2006, 06:31
Default Increase maxsc2
  #1
Konstantinos
Guest
 
Posts: n/a
Hi,

Could someone please tell me how do I increase maxsc2? I know how to increase the memo maxcut but is there any other way?

Thanks, Konstantinos
  Reply With Quote

Old   March 5, 2006, 07:35
Default Re: Increase maxsc2
  #2
Wael
Guest
 
Posts: n/a
Hi. You can increase MAXSC2 like MAXCUT " MEMORY MAXSC2 NUMBER" or in the parm info file you can increase the number and save it..... I noticed that the MAXSC2 is different in the parm info file and the one in the output window "MEMORY LIST ALL", If one of the respected users can inform us about that differenc, it will be good. Wael
  Reply With Quote

Old   March 5, 2006, 09:48
Default Re: Increase maxsc2
  #3
Wael
Guest
 
Posts: n/a
sorry parm.inc not parm.inf
  Reply With Quote

Old   March 5, 2006, 17:32
Default Re: Increase maxsc2
  #4
Alex
Guest
 
Posts: n/a
Don't edit parm.inc, you'll only get yourself into trouble. Use "memo maxsc2 ####" followed by "memo write" which writes out a new parm.inc, saving the changes for your next session.
  Reply With Quote

Old   March 5, 2006, 18:29
Default Re: Increase maxsc2
  #5
Konstantinos
Guest
 
Posts: n/a
Thanks to both of you guys! I havent tried it out yet, but I have the feeling that what you said will work!

Konstantinos
  Reply With Quote

Old   March 6, 2006, 06:06
Default Re: Increase maxsc2
  #6
Konstantinos
Guest
 
Posts: n/a
Somethine wierd is happening, the program asks for a certain number of maxsc2, although the maxsc2 i have specified is larger than what it asks!!! This is crazy! lol Does anyone know why this could happen?

Thanks, Konstantinos
  Reply With Quote

Old   March 6, 2006, 06:19
Default Re: Increase maxsc2
  #7
Konstantinos
Guest
 
Posts: n/a
Hi again,

I get this message:

*** GEOMETRICAL CALCULATIONS STARTED BEGINNING CELL TO WALL DISTANCE CALCULATION *** ERROR: NPEAK: 13828 In box 4 6 1 in processor 1

SET MAXSC2 to at least 13829000 , then re-run (use option -nodecomp in parallel)

*** ERROR #020 *** TOO MANY CELLS IN NEAR-WALL LAYER.

SELECT A SMALLER SET OR INCREASE PARAMETER MAXSC2 IN parm.inc PNP: Shutdown [2006-03-06-10:19:55] Execution aborted by request (SIGABRT) after 168 seconds (TOTAL ELAPSED TIME).

I have tried increasing maxsc2 but it doesnt work, maybe I should try selecting a smaller set, but how do I do that?

Konstantinos
  Reply With Quote

Old   March 6, 2006, 20:04
Default Re: Increase maxsc2
  #8
Wael
Guest
 
Posts: n/a
Hi. I had the same problem before. I changed the MAXSC2 in the parm.inc (Also, the value in the parm.inc file is smaller that in the model. I do not know why) and it work well. I know it is not good to change in the parm.inc but I do not know other way. If someone know, it will be of great imortance to us. Best wishes. Wael
  Reply With Quote

Old   March 7, 2006, 05:19
Default Re: Increase maxsc2
  #9
Konstantinos
Guest
 
Posts: n/a
Yeah, changing it through the output window doesnt have any effect. But even when I change it through parm.inc , sometimes it changes sometimes it doesnt. I might change it and save it and then for no reason when I run the program it returns to the previous value, or it might just not return and the program runs. But I cant find the pattern about when this happens. Also, in parm.inc there are two values for maxsc2, should i change both?
  Reply With Quote

Old   March 7, 2006, 08:34
Default Re: Increase maxsc2
  #10
TG
Guest
 
Posts: n/a
You guys are confusing parm.inc with param.prp. param.prp is the size file for prostar and that's the only one that the memory command changes. parm.inc is size file for star. prostar writes that file and you can't influence what's written. If its not writing a big enough number its probably a bug.
  Reply With Quote

Old   March 7, 2006, 08:42
Default Re: Increase maxsc2
  #11
Konstantinos
Guest
 
Posts: n/a
But u cant alter param.prp so what can u do...
  Reply With Quote

Old   March 7, 2006, 08:48
Default Re: Increase maxsc2
  #12
TG
Guest
 
Posts: n/a
You can alter param.prp - use the prosize program or do a memo,write after changing an internal prostar memory parameter.
  Reply With Quote

Old   March 8, 2006, 09:06
Default Re: Increase maxsc2
  #13
mg
Guest
 
Posts: n/a
A PARAMETER MAXSC2 ist used both for PROSTAR (in file param.prp) and for STAR (parm.inc).

You Change file param.prp using the PROSIZE program or the memory command inside of PROSTAR.

You should'nt change parm.inc. This is written during geomwrite und updated (if necessary) during probwrite. In this case you have a new file parm.new that you have to rename in parm.inc.

File parm.inc will be changed once again during decomposing, if you use a parallel version of STAR. The behaviour in this STEP ist different for STAR 3.15 and STAR 3.2. Which Version are you using ?
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tetrahedral quality improvement - MAXSC2 limit Ankush Aggarwal CD-adapco 1 July 11, 2006 01:10
MAXSC2 furkan CD-adapco 1 May 15, 2006 05:50
maxsc2 problem Tristan CD-adapco 3 December 16, 2005 10:57
about the allowed maxsc2 limingtiger CD-adapco 0 August 23, 2005 21:04
MAXSC2 memory error Arnab CD-adapco 3 January 23, 2005 19:14


All times are GMT -4. The time now is 12:23.