CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CD-adapco

CCM+ bad_alloc

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 1, 2006, 04:28
Default CCM+ bad_alloc
  #1
AJ
Guest
 
Posts: n/a
Does anyone know anything about "bad_alloc" errors in starccm+?? Occurs when I try and run the model. What could be causing this? How do I prevent it?! Thanks
  Reply With Quote

Old   May 1, 2006, 10:54
Default Re: CCM+ bad_alloc
  #2
TG
Guest
 
Posts: n/a
save your model after meshing. shutdown ccm+ and then restart it.
  Reply With Quote

Old   May 2, 2006, 11:38
Default Re: CCM+ bad_alloc
  #3
Chris
Guest
 
Posts: n/a
bad_alloc is the standard c++ out of memory error. It probably failed to allocate enough space for the solution data.

As TG wrote, if you just generated the mesh, re-starting may allow you to proceed. If not, you may need more memory or a smaller mesh (fewer cells).

  Reply With Quote

Old   May 2, 2006, 16:30
Default Re: CCM+ bad_alloc
  #4
Steve
Guest
 
Posts: n/a
Now THAT sounds like something Micro$oft would offer you as a solution to bad code!
  Reply With Quote

Old   May 3, 2006, 11:33
Default Re: CCM+ bad_alloc
  #5
tina
Guest
 
Posts: n/a
try changing to explicit! and change the Courant no to very small for the begining say 0.1
  Reply With Quote

Old   May 5, 2006, 10:18
Default Re: CCM+ bad_alloc
  #6
Chris
Guest
 
Posts: n/a
In fact this problem is worse on windows for various reasons. Try googling "heap fragmentation windows" ...

  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 10:01.