CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CD-adapco (
-   -   events (

student May 22, 2006 11:10

Hi all,

I am writing events for compression stroke such that cells deactivate as the piston reach at the center of cell dimension(which is ofcourse same for whole layer). For expansion stroke I am writing events such that cells activate as piston reach at the starting of cell dimension (again same for whole layer).

If I give command EVLOAD UPTO DEGREE 180 then I get piston position at TDC. Now after EVLOAD RESET, if I give command EVLOAD UPTO DEGREE 190 then I get error at first event of expansion stroke saying check your grid change command & 400 active cells with zero volume (which is because I have activated first layer at the begining point of cell layer). I have used same method for writing grid change command as well as events as explained in tut-13.

Important- I tried same commands for tut-13 and the result was same. Then I went for enimation and while loading events throughout 360 degree I did not get that error.

Question- Why I dont get error while loading events for enimation? Is it necessary that I write events for activation of cell layer at the mid point also (which is not the case mensioned in tut-13)?

Strange- I had two solver runs that went passed through this piston position and they also gave me same error while preprossesing. But now I get that error back again in solver. Run stops saying negetive density. While checking .info file I came to know that the error occurs at the same piston position,i.e. execution of first expansion event.

please help,

I would really appreciate your quick responce.

All times are GMT -4. The time now is 16:07.