CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CD-adapco (http://www.cfd-online.com/Forums/cd-adapco/)
-   -   lack of support for VOF in version 3.26 (http://www.cfd-online.com/Forums/cd-adapco/55531-lack-support-vof-version-3-26-a.html)

Tom July 31, 2006 12:03

lack of support for VOF in version 3.26
 
Can anyone tell me what the problem is on running VOF in version 3.26? When you set the write frequency, the code stops when it reaches the first write point and you cannot access the pstt file. If you write a pst file, you will be able to access it; however, running the problem as a series of steady state runs takes up lots of disk space.

I have asked everyone I could in adapco tech support; I asked our sales rep to find out for me; I have asked people I know in model development - no one can get an answer for me.

The closest to a response I have gotten is to use version 4. However, because of our code control, I can not. Also, each person that has told me that also admitted on further questioing that they personally have not tried VOF on version 4.

Never before has cd-adapco provided so little support for any problem I have had. I am very disappointed so I am turning to you for help.

Tom

William Blake July 31, 2006 12:57

Re: lack of support for VOF in version 3.26
 
It's the same with cavitation (also based on VOF). Either use V320 or V4 or CCM+.


Ben July 31, 2006 13:09

Re: lack of support for VOF in version 3.26
 
I must admit I am supprised by the lack of support, I have always found it rather good. Have a go and push it further, I am sure if you complain enough you will get some progress, get them a test case that shows the bug easily that way they can't ignore it. Although I would say that nagging your tech guys to install 4 is a good idea, the VOF model is a hell of a lot better as it uses the COMET model so the results are going to be a lot better.

Tom July 31, 2006 13:15

Re: lack of support for VOF in version 3.26
 
I have provided my tech guy with the problem and his response is, "You are right. It should work, but doesn't. I can not get any one to help me with it either..."

I work in the nuclear industry and we have very harse code control rules. I am not allowed to have two versions of the same code operating at the same time. Because I am doing boiling and two phase flow work I am required to use version 3.26. Version 4 or going back to 3.24 is not an option. This has been going on for at least two months.

Tom

John August 1, 2006 10:14

Re: lack of support for VOF in version 3.26
 
It seems your problem is very simple and strange that nobody answers your qury efficiently (sound like Adapco quality). STAR 3.26 works the same as previous versions aside from PROSTAR transient setup (if you want, you can still use Transient load step setup in Modules). But normally, You control output of .pst and .pstt file through Analysis Controls=>Output Controls=>Analysis Output then you choose what time interval to output data. The overall run time is controlled: Analysis Preparation/Running=>Set Run Time Controls: you input for how long you want to run and dt etc. I think tut15.1 should guide you to that.

It is always a wishful thinking that next version problem disappears. STAR4 VOF and STAR3 VOF use the same methodology and scheme, the difference is very minor. There is no COMET magic.


Tom August 1, 2006 11:05

Re: lack of support for VOF in version 3.26
 
John, have you tried this for VOF? I did, and followed tut 15.1 step by step. It still would not write a pstt file that could be read. The tech support guy did the same with the same results. Now he says it is my model. This model has been used for other transient analysis and benchmarked successfully. What in a model would prevent it from writing a pstt file in VOF but would in other transients? Tom

John August 1, 2006 11:18

Re: lack of support for VOF in version 3.26
 
I have run many VOF cases in STARV3.26. Does tut15.1 work for you?

If you cann't make .pstt file store data. Maybe one workaround is to store multiple of .pst file Analysis Controls=>Analysis Output=> then click POST, then put a number in backup frequency (say 100, then you will have .pst_100, .pst_200 etc).

Any possible solution is to turn off Subcycling (personally I prefer no subcycling). Try setting REAL CONSTANT 194 to 1 which will fix your time step for running.

Tom August 1, 2006 11:32

Re: lack of support for VOF in version 3.26
 
Thanks. I will try setting the switch and let you know how it goes. Tom

student August 2, 2006 05:50

Re: lack of support for VOF in version 3.26
 
hy I had also the pb with this vof and I think the problem was that the pstt file is to big to be read I reduce the number of write frequency and it worked.. Can someone explain the difference between subcycling off and on (which one is the more accurate)??? Also what is the REAL CONSTANT?? I use VOF with the option Surface tension ON and they say that you have to put smaller time steps if you are using Surface tension ON what are small time steps if I use a velocity magnitude in inlet 10E-01m/s? thanks for your helping your help are very usefull

Kerkuyan from Hamburg August 4, 2006 16:25

Re: lack of support for VOF in version 3.26
 
Subcycling is useless, we made a test and the CPU time is increased 1200% for 0.4% increase in accuracy: Krap.

K.

student August 6, 2006 08:20

Re: lack of support for VOF in version 3.26
 
are you sure of it So you mean that i should put it off And how much should I put in the times scale if I put it off yo know there is a number case to fill in Also wath orther of time step sohould I put for my pb it is a buble in a 0.4cm tube with a speed of 0.1m/s and a surface tension about 0.04 and I have a second analysis with 0.004 surface tension How I choose my time step


All times are GMT -4. The time now is 18:27.