CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CD-adapco (
-   -   plotting field data (

thomas November 14, 2006 13:42

plotting field data
Hello, I am trying to plot field data along a line in my domain. Star cd offers the option of selecting the line by picking the endpoints with the cursor. However, since I am trying to compare different grids, this is not accurate enough. In the pull down menu on the graph tab where the line definition method can be chosen, there is also the option to specify a point and a vector. This is what i want. For some reason though this option appears in grey and cannot be picked. There is nothing in the manual about conditions under which this option is disabled. It's driving me crazy! Has Anyone ever encountered this problem?or knows a possible solution to it?

I would be very thankfull


Pauli November 15, 2006 11:13

Re: plotting field data
For me, that option is not greyed out. I am using Prostar 3.26 under Redhat Linux. You should report that to support. It sounds like a bug.

That option uses the gpost command with the points option. Do a "help gpost". Run it from the command line then graph the results.

thomas November 15, 2006 12:59

Re: plotting field data
Thank you,

it works now. I'm also really starting to think there could be a bug in the windows version of the GUI.(I did email support and they told me that they don't deal with students directly and that I should ask my supervisor to contact them...)

which leads straight to my next question: the number of sensor points is the number of actual points used for the graph, isn't it? so i would like to print the graph register to a file or the screen, in order to export the data to a different software, because i want to compare them to the graphs of different meshes. I found a command which prints the graph registes to a file. I told it to print what I thought were the relevant registers and was expecting a file with two columns of 20 numbers, but I got a file with thousands of numbers without any order to them. Do you have any suggestions how this could be done?

Thanks again for your effort,


Pauli November 16, 2006 11:08

Re: plotting field data
In the gpost command you tell it a register to load the sensor data (IREGS). You need to point to that same register when you save to a file using the sdata command.

Before you issue the gpost command, use greset or rclear to empty out the graph registers. You may be dumping old information.

Alternatively, you can use the sensor command to list the values to the screen.

thomas November 16, 2006 12:23

Re: plotting field data
thanks, I have looked up the register number in which the relevant data is stored. I then ran sdata, telling it to print only this register. In the output window it is then stated, that the register has been dumped to the file. The file appears in the working directory, but it is empty.

I do not really understand this, because if I run Sdata on a register which I know to be empty, an error number occurs.

is there a trick to it?


Pauli November 16, 2006 19:09

Re: plotting field data
Prostar is not flushing the file write buffer.

Try issuing: close file_name or close all

All times are GMT -4. The time now is 05:24.