CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CD-adapco

how to avoid self intersection:Proam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 29, 2008, 06:26
Default how to avoid self intersection:Proam
  #1
bala
Guest
 
Posts: n/a
Hi all,

I am getting self-intersection after generating the subsurface eventhough if i enable avoid self intersection in advanced options. The interesting thing is the self-intersections are not in the subsurface regions but some were in the model. How to avoid this error?
  Reply With Quote

Old   February 29, 2008, 14:04
Default Re: how to avoid self intersection:Proam
  #2
Tom Keheley
Guest
 
Posts: n/a
Try doing it manually. Select the cells where the self intersecting is happening and change them to a different cell type. Then use the advanced options in the subsurface generation panel to set these cells at a diffent thickness.

Another way is to just set all cells at the lower value, but this will screw up more y+ values. Good luck, Tom
  Reply With Quote

Old   March 1, 2008, 10:03
Default Re: how to avoid self intersection:Proam
  #3
nava
Guest
 
Posts: n/a
hello Tom & all.

I have the same self-intersecting problem after the sub-surface generation.

I have a duct model, in which i have a sharp corners. after sub surface generation i found that the subsurface is going up and intersecting with surface in the sharp corner.

I have tried playing with advanced options and different cell thickness for the region where i am getting problem. but nothing works the way i excepted.

The one way may be putting the intersecting region to no sub-surfrace. but that doesn't make any sense since the region is very critical to the flow.

Do any one know, how to solve this.?

Regards,

nava
  Reply With Quote

Old   March 2, 2008, 21:13
Default Re: how to avoid self intersection:Proam
  #4
airfoil
Guest
 
Posts: n/a
Hi all,

Sometimes I also got the same self-intersection error although I knew my shell surface was clean. What I did was, I would do a surface check before I proceed to sub-surface generation. Then I find attach those self-intersection shell and re-create new shell on those area. * To find attached shell, I use this method 1. new vertex set -> cell set 2. new cell set -> vertex set any

Hope this will help!

Airfoil

  Reply With Quote

Old   March 3, 2008, 19:55
Default Re: how to avoid self intersection:Proam
  #5
Andrea
Guest
 
Posts: n/a
You can also plot a contour plot with surface+subsurface and by that plot you can find intersectiong cell (subsurface menu->Plot...->Subsurface and Thickness Contour). The you can try to remesh the intersecting zone of the surface and then doing a new subsurface or you can change cell type in that zone and create a subsurface with different wall tickness
  Reply With Quote

Old   March 6, 2008, 05:23
Default Re: how to avoid self intersection:Proam
  #6
Anton Lyaskin
Guest
 
Posts: n/a
In the Advanced Subsurface Options there are two parameters which can help with self intersection problem - number of iterations and relaxation factor.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Polyline at intersection of two planes Francesco CFX 2 July 29, 2009 08:03
Now really how to avoid the dimensions vitke OpenFOAM Running, Solving & CFD 8 August 30, 2007 07:58
processors to avoid richard Main CFD Forum 4 March 7, 2006 16:22
how to avoid zero volume elements sameer CFX 1 February 2, 2006 20:10
3d-pipe intersection in same plane Pravir Kumar Rai FLUENT 3 February 26, 2002 14:56


All times are GMT -4. The time now is 07:12.