CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CD-adapco (http://www.cfd-online.com/Forums/cd-adapco/)
-   -   Cannot run Star-CCM+ parallel in Linux (http://www.cfd-online.com/Forums/cd-adapco/56604-cannot-run-star-ccm-parallel-linux.html)

dburns May 7, 2008 10:55

Cannot run Star-CCM+ parallel in Linux
 
I have installed Gentoo linux and I cannot run parallel in linux. I have no problem running parallel on my windows machines. The error is as follows:

/opt/cd-adapco/starccm+3.02.003/star/bin/starccm+: line 470: rpm: command not found

Starting STAR-CCM+ parallel server

poll: protocol failure in circuit setup

p0_28674: p4_error: Child process exited while making connection to remote process on p4-lnx: 0

p0_28674: (4.031250) net_send: could not write to fd=4, errno = 32 Stopping server

Am i missing something in my linux installation?

Truckman May 7, 2008 15:37

Re: Cannot run Star-CCM+ parallel in Linux
 
same as the other idiots, don't use a dodgy linux system

TG May 7, 2008 17:16

Re: Cannot run Star-CCM+ parallel in Linux
 
STAR-CCM+ is tested on RH Enterprise and Suse Enterprise. It is not guaranteed to work on any other linux versions and you will not get support on other linux versions. Having said that, the problem is that the master node can't rsh to the other nodes its trying to use. If you can't do rsh node2 w from node1 then it won't work.

Paulh May 8, 2008 14:06

Re: Cannot run Star-CCM+ parallel in Linux
 
Perhaps your system requires a secure shell to log into another machine. Try the CCM+ command line option:

-rsh ssh

paulh

dburns May 9, 2008 18:49

Re: Cannot run Star-CCM+ parallel in Linux
 
TG, you are correct, they do not support Gentoo. Paulh, I tried the -rsh /usr/bin/ssh command and I still get the same error. Truckman, thank you for sharing your infinite wisdom.

TG May 11, 2008 14:28

Re: Cannot run Star-CCM+ parallel in Linux
 
It means that you don't have rsh configured correctly. Either create a .rhosts file (man rhosts) or change your /etc/hosts.equiv file. I suspect you just aren't allowing rsh and that's all you have to fix.

dburns May 12, 2008 10:16

Re: Cannot run Star-CCM+ parallel in Linux
 
"no manual entry for rhosts" and I have no /etc/hosts.equiv file. I thought I installed and configured rsh properly. I followed a guide on creating a Beowulf cluster. Here's what my /etc/xinetd.d/rsh looks like...

service shell

{

socket_type = stream

protocol = tcp

wait = no

user = root

group = tty

server = /usr/sbin/in.rshd

log_on_success = PID HOST USERID EXIT DURATION

log_on_failure = USERID ATTEMPT

disable = no

}

I added it to the default run group -Thanks for the help!

dburns May 14, 2008 08:34

Re: Cannot run Star-CCM+ parallel in Linux
 
Maybe I should clarify that I can't run in parallel on this linux machine with a dual processor.

dburns May 16, 2008 12:05

Re: Cannot run Star-CCM+ parallel in Linux
 
You were correct! I configured ssh and it works perfectly!

Thanks!

Pierpaolo April 27, 2010 12:01

Hi,
got the same hitch here on gentoo. Could you please share what you exactly did.

Thanks


All times are GMT -4. The time now is 15:16.