CFD Online URL
[Sponsors]
Home > Forums > CD-adapco

moving mesh in parallel mode

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 13, 2008, 07:43
Default moving mesh in parallel mode
  #1
Karteek
Guest
 
Posts: n/a
Hi, I am trying to implement a moving mesh model which has 5 sliding interfaces using ASI in parallel mode in linux. It is a huge model with around 5000000 cells. I have divided the mesh manually into 8 sets ensuring that the attach boundaries at an interface are in the same set. I run the moving mesh on a separate node and so in total use 9 nodes for processing. But after the code runs for about 1000 secs it errors out saying sigkill signal has been sent from the node running the moving mesh. When I check the mvmesh.log file I find that star-cd has defined some parameters as given below which I have not defined either in the macro file nor in the .cgrd file.

*SET ITER 0 0.0

*SET EVNO -1 0.0

*SET EVEX 1 0.0

*SET LSTP 1 0.0

*SET TIME 0.00000000 0.0

*SET ETIM -1.0000000 0.0

*SET YPST 0.00000000 0.0

Also there is no further use of these parameters in the mvmesh.log file. The events run as defined once for time=0 and then it stops. I would be grateful if anybody could help me out.

Regards

  Reply With Quote

Old   June 13, 2008, 12:02
Default Re: moving mesh in parallel mode
  #2
Pauli
Guest
 
Posts: n/a
Huge is a relative thing. Now days some folks think 5M cells is normal. And a few think that's small!

Those parameters are generated by STAR to assist in the event process. It is up to the user to do something with them.

Going from memory, I believe they are:

ITER = current iteration

EVNO = next event to be executed

EVEX = last event executed

LSTP = current load step - from the old multi-step transient approach

TIME = current simulation time

ETIME = time next event occurs

YPST = Piston position - for IC engine jobs - works with the evparm,piston command

Since your run goes for 1000sec, you must have a bunch of stuff correct. Having the moving grid node sigkill makes me suspect your grid change commands did something ugly. Hard to say without knowing the specifics. Does the problem repeat? Does it repeat at exactly the same time? Is it near or past your last event? I would be looking for something that creates a divide by 0 or array out of bounds type condition.
  Reply With Quote

Old   June 14, 2008, 11:39
Default Re: moving mesh in parallel mode
  #3
Karteek
Guest
 
Posts: n/a
Hi,

Thanks for helping me out in understanding the variables. The error actually was a pretty stupid mistake in the moving mesh commands. The model is running now.
  Reply With Quote

Old   June 16, 2008, 04:58
Default Re: moving mesh in parallel mode
  #4
ELYOR
Guest
 
Posts: n/a
Hello Mr. Karteek, I am also trying to do moving mesh in parallel mode, could you please help me on SETS, how to do manual sets. Which command do i have to use (like decompmethod = sets..) model has about 180000 cells.

thanks an advance for your help.
  Reply With Quote

Old   June 16, 2008, 05:12
Default Re: moving mesh in parallel mode
  #5
Karteek
Guest
 
Posts: n/a
Hi, You would need to manually define sets using prostar with the setw command ( try help setw). Once you define them a file casename.set is created. While using star when you use decompmeth=s star-cd uses the .set file
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
A UDF Problem in Parallel Mode Jun FLUENT 1 October 26, 2011 13:49
Parallel moving mesh problem lr103476 OpenFOAM Running, Solving & CFD 29 November 26, 2008 02:55
how to parallel run in moving mesh case ELYOR CD-adapco 5 June 16, 2008 04:23
How to specify the mesh moving mode in CFX Jemy CFX 2 August 27, 2007 21:04
How to run his phoenics in parallel mode? Bryan Lam Phoenics 3 December 19, 2001 10:43


All times are GMT -4. The time now is 04:03.