CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CD-adapco (http://www.cfd-online.com/Forums/cd-adapco/)
-   -   Modeling heat transfer through a pipe (http://www.cfd-online.com/Forums/cd-adapco/82731-modeling-heat-transfer-through-pipe.html)

Kristofer December 3, 2010 17:04

Modeling heat transfer through a pipe
 
Hello,
This is my first time attempting to model utilizing Star CCM+ 5.0.2, and I am finding it is a very powerful tool. I have a heated air flow through a pipe that is experiencing natural convection on the outside. To model this I created two bodies, one for the heated flow, and one for the solid body. I then made a contact surface interface between the two. The outside of the pipe boundary was assigned as convection with room temperature as the constant temperature.
I get heat distribution within the fluid flow, but I get nothing through the solid region. I am trying to determine what conditions I should be setting at the boundaries. Any help would be appreciated.

Jonny6001 December 3, 2010 19:01

Hello, I should be able to help you with this.

If you want to specify a consant convective coefficient then some of what you are doing is right. You can get a range that the 'h' value should be either from books or experimental. Books usually quote a range 2-25W/m2K, this is a pretty big range though.

I take it that your interface between the pipe and gas region is a contact interface?
You have a separate physics continuum for the gas and solid? Have these been chosen correctly in the 'region' area of the tree?

I can help you some more if you are a little more specific or post a screenshot of what you mean and some of the case tree.

I was recently having issues correlating a natural convection case when trying to actually model the buoyancy driven flow around the pipe, I eventually achieved good correlation.

Kristofer December 3, 2010 19:50

2 Attachment(s)
Hello Johnny,
Thank you for responding so quickly. I did create the interface as an in-place/contact surface. I have a velocity inlet, and a pressure outlet. I have set the inlet temperature to a constant 350K, with a velocity of 20 m/s. I am currently using a heat transfer value of 10 W/m^2*K. I think the issue I am having is with the thermal specification of the boundaries that make up the interface on the inside of the pipe. I do not want to set a constant temperature, nor convection, and the heat flux should be variable. I have attached the report which has most of my stuff included, not sure if it will help or not, but I am beating my head against a brick wall at this point.

Jonny6001 December 3, 2010 20:25

The interface between the inside wall of the pipe and the hot gas should be a contact in-place interface and that's it, nothing else.
You can request a 'heat transfer' report for this interface to see if any heat is being transfered across the boundary.

You can try and set the external pipe walls to adiabatic, this means the external heat flux is zero. This should mean that the gas and pipe would converge to a constant temperature of 350K if heat is allowed to cross the internal interface. This would at least let you know if your interface is working correctly.

Another issue you could have is the tolerance on the interface is set too low. If the mesh is too coarse and the two bodies do not touch, if the interface tolerance is too low then the two bodies will not be considered to be in contact even though you have specified it.

Do you have 2 separate physics continuum, one for the gas and one for the solid? This is right at the top of the tree. And these need to be set for their coressponding regions.

Kristofer December 4, 2010 14:01

Ok, I checked my interface coarseness and it seems to be in good contact. I have the two different bodies assigned to proper regions/meshes. I generated a plot showing the heat transfer through the interface and I am getting a consistent zero at the first 50 iterations. I think this is enough iterations as i have achieved steady state on most of my residuals. I am completely at a loss as to why I can't seem to get simple heat flowing through this boundary(in-place/contact surface).

Kristofer December 5, 2010 15:14

Hello Johnny,
So I took a second look at my interface contact and you were right, the mesh density was too coarse to provide good interface. The problem was that if I increased the density too much, none of the computers available could run the simulation without shorting on memory. So I ended up sectioning the pipe into 6 pieces and running one of those as the simulation. Doing this I was able to increase the mesh density by more than 5 magnitudes, and got fantastic results. Thank you so much for the help.


All times are GMT -4. The time now is 05:56.