CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

Can someone explain me this error?

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 21, 2012, 11:24
Default Can someone explain me this error?
  #1
Senior Member
 
kbaker's Avatar
 
Khalid Baker
Join Date: Mar 2009
Location: IRAQ
Posts: 118
Rep Power: 8
kbaker is on a distinguished road
Hi when I run my simulation the error below appeared after nearly 15 iterations:

A wall has been placed at portion(s) of an OUTLET boundary condition (at 100.0% of the faces, 100.0% of the area) to prevent fluid from flowing into the domain.
The boundary condition name is: outflow.
The fluid name is: Water.
If this situation persists, consider switching
to an Opening type boundary condition instead.

may somebody tell me what its reason?

Thanks
kbaker
kbaker is offline   Reply With Quote

Old   May 21, 2012, 11:41
Default
  #2
Senior Member
 
Lance
Join Date: Mar 2009
Posts: 522
Rep Power: 11
Lance is on a distinguished road
Use the forum search function, this is one of the most common questions asked...
Lance is offline   Reply With Quote

Old   May 21, 2012, 12:00
Default
  #3
Senior Member
 
kbaker's Avatar
 
Khalid Baker
Join Date: Mar 2009
Location: IRAQ
Posts: 118
Rep Power: 8
kbaker is on a distinguished road
ِAs I saw from the other posts about this error some suggests to solve the problem with moving the exit boundary further away from the inlet to prevent reverse flows I need to say my pipe length is 25 m and diameter is 98.5 mm so I think the inlet is located in a far distance from the outlet ? I am right or I need really to make the pipe longer?

Last edited by kbaker; May 21, 2012 at 14:49.
kbaker is offline   Reply With Quote

Old   May 21, 2012, 18:36
Default
  #4
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 10,646
Rep Power: 84
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
Your warning is saying 100% of the outlet has backflow. In this case the problem is more fundamental as none of the outlet is working as expected. You need to look into why the entire outlet wants to flow backwards.
ghorrocks is offline   Reply With Quote

Old   May 21, 2012, 18:41
Default Hi
  #5
Senior Member
 
Danial
Join Date: Nov 2011
Posts: 179
Rep Power: 5
Danial Q is on a distinguished road
Try this, it might work for you;
Expert parameters > Discretization > Miscellaneous > Build artifical wall > set to " f ". By default its "t". F will not build any artifical wall and try to reduce your time steps also.

cheers
Danial Q is offline   Reply With Quote

Old   May 21, 2012, 18:43
Default
  #6
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 10,646
Rep Power: 84
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
Sorry Danial, this is a bad idea. Something is wrong with the simulation and that is making the flow want to go backwards. Rather than letting it go backwards you should fix the root cause of the problem, and make the flow want to go forwards.
ghorrocks is offline   Reply With Quote

Old   May 22, 2012, 10:38
Default
  #7
New Member
 
Join Date: May 2012
Posts: 6
Rep Power: 5
piyo is on a distinguished road
In CFX, when the outlet condition is used, the solver will build an artifitial at outflow position to allow for outflow but prevent backflow. As been recommanded, this setting should not be switched off in expert parameters in most time. If your position has backflow in real case, you'd better use opening condition, and of course, requiring more time to converge.
piyo is offline   Reply With Quote

Old   May 22, 2012, 11:00
Default
  #8
Senior Member
 
kbaker's Avatar
 
Khalid Baker
Join Date: Mar 2009
Location: IRAQ
Posts: 118
Rep Power: 8
kbaker is on a distinguished road
The message disappeared when I use double precision and switch to segregated treatment for the volume fraction coupling and reduce time step to 0.001 s and I still use outlet boundary but the results shows higher liquid level which I define it at inlet and outlet as the same with value 5.5 mm (where pipe diameter is 98.5 mm) and it seems more higher than expected with unknown reason?

Last edited by kbaker; May 22, 2012 at 15:07.
kbaker is offline   Reply With Quote

Old   May 22, 2012, 19:07
Default
  #9
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 10,646
Rep Power: 84
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
So it seems the outlet back flow was due to problems converging. This confirms you should fix the root cause of the problem and not just allow back flow to occur.

Your question about accuracy is an FAQ: http://www.cfd-online.com/Wiki/Ansys..._inaccurate.3F
ghorrocks is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
GroovyBC the dynamic cousin of funkySetFields that lives on the suburb of the mesh gschaider OpenFOAM 300 October 29, 2014 19:00
c++ libraries and solver compiling vaina74 OpenFOAM Installation 13 February 3, 2012 18:43
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 20:50
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 17:51
user defined function cfduser CFX 0 April 29, 2006 10:58


All times are GMT -4. The time now is 18:16.