CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   cfx ansys FSI error (http://www.cfd-online.com/Forums/cfx/104043-cfx-ansys-fsi-error.html)

cyy July 2, 2012 09:05

cfx ansys FSI error
 
hi
my simulation often suddenly stopped with the error:

ERROR #002100061 has occurred in subroutine SERVE_CLIENTS. |
| Message: |
| The connection between this CFX process and an external process |
| has died unexpectedly. The following error was received: |
| External process : ANSYS |
| Error experienced : Read

Anybody can help?
Is it my computer that contributes to the failure?
can i restart it? since i have the .bak file at 163 step, but the time step of ansys is 190(i only got a .rst file,not the .res file)

Many thanks!!

sorrego July 2, 2012 15:22

Hello.
Sure you can restart your simulation using your backup file. Be careful when analyzing the data in CFX-Post, make sure you have all your timesteps results with you.
I have no idea the cause of your problem.
Santiago.

cyy July 2, 2012 21:59

Quote:

Originally Posted by sorrego (Post 369353)
Hello.
Sure you can restart your simulation using your backup file. Be careful when analyzing the data in CFX-Post, make sure you have all your timesteps results with you.
I have no idea the cause of your problem.
Santiago.

thank u for ur reply!
I tried to restart with the .bak file at 163 steps and the .rst file, but the ansys convergence failed, i guess it may be because the steps of the .rst file is not the same as the .bak file. some one said i should have the .rnnn flie, but i canot found it in my reslut file.
the command i uesd is : mfou,1
should i also use the the command:mfrc?

omidiut July 3, 2012 02:30

Hi Dear cyy
It is a very common error in FSI simulation, and may have several reason. its occurs when transferring data between cfx solve and ansys solver failed.

try using smaller time step and refine your mesh quality in solid domain, make sure that there is not any warning or Error in solid setup cell.
if you explain what is your problem i can help you more.
Best regards.

cyy July 3, 2012 03:50

Quote:

Originally Posted by omidiut (Post 369433)
Hi Dear cyy
It is a very common error in FSI simulation, and may have several reason. its occurs when transferring data between cfx solve and ansys solver failed.

try using smaller time step and refine your mesh quality in solid domain, make sure that there is not any warning or Error in solid setup cell.
if you explain what is your problem i can help you more.
Best regards.

many thanks,omid.
yes,the mesh in ansys has a warning.
as the solid model has a high aspect ratio(L/d~10000), also i find the number of the solid cells influence the time consuming of the FSI significantly, so i set the size of the cell in L direction very large to reduce the total cell number, then the aspect ratio of the cells in ansys is also large, and this is why the warning appear, i guess.

but i think i can't refine my mesh to satisfy the requir of ansys, which will lead to a too large number of cells.

originally, i just think i can restart FSI just from where the simulation crashed.
then what's ur advice?

omidiut July 4, 2012 00:08

Try other mesh method, as sweep or multizone. in mesh sizing details, turn off "Use advanced size function". you can use edge sizing for have more control on mesh quality.

cyy July 4, 2012 03:39

yes,I meshed it in ansys APDL,using sweep method. i will try other method.
thank u~

kqlee August 27, 2012 22:31

Dear everyone,

hi,

I'm facing the similar problem with cyy.

When running the simulation, warning occurs in ansys:

*** WARNING *** CP = 1.014 TIME= 13:51:26
The /BATCH command must be the first line of input. The /BATCH command
is ignored.

*** WARNING *** CP = 1.342 TIME= 13:51:35
ANSYS results must be written into the database for Multifield
analysis. The /CONFIG,NOELDB,1 command is ignored.

*** WARNING *** CP = 14.648 TIME= 13:52:05
Element shape checking is currently inactive. Issue SHPP,ON or
SHPP,WARN to reactivate, if desired.

*** WARNING *** CP = 14.742 TIME= 13:52:05
Material number 2 (used by element 12900 ) should normally have at
least one MP or one TB type command associated with it. Output of
energy by material may not be available.

after several iterations, it stops with the error same as cyy.

Is there anyone can help with this problem? Thank you and have a nice day.


All times are GMT -4. The time now is 09:28.