CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   Turbomode of CFX (http://www.cfd-online.com/Forums/cfx/105204-turbomode-cfx.html)

c120613 July 25, 2012 05:23

Turbomode of CFX
 
Dear all,

I'm trying to post-process in CFX and use the turbomode of CFX. I've got a compressor fan having a certain number of blades and I'm interested to see and compare trends of quantities along the span location averaged along the circumferential domain of each blade passage. By default, the initialization in turbomode take into account the full annulus and the initialization can be done only if the option '360 Case without Periodics' is enabled. Then, I used to define the sub-domains (hub, shroud, blade, inlet, and outlet), referred to only one specific blade passage. However there are no differences against the full annulus solution. In fact, if I try to plot the Turbo chart 'Hub to Shroud' the trend of a quantity (which is averaged along the circumferential direction) along the span is always the same. It seems that the limit of the circumferential location over which the average of the quantity is done is always from 0 to 360 degree, even though the Turboregions are referred to a specific blade passage.

Does anyone knows how I can solve this problem instead of creating matlab codes to divide the information between blades?

Thank you in advance for your collaboration

ismael.s July 26, 2012 08:38

Hello.

Is your geometry a periodic of the fan or the full geometry? 360 I mean.

Can you post an Isometric view of your fan?

c120613 July 26, 2012 08:53

Turbomode
 
1 Attachment(s)
It is a full annulus. You can see from the picture. The mesh was originally created by means of Turbogrid and automatically for each blade there are the sub-domains defined. Do you have then an idea how to separate the post-processing according to the blade passage?

Thank you in advance for your collaboration

ismael.s July 26, 2012 09:02

I usually separate the blade passage when I draw on CAD software.

In the POST, do you try to initialize just the impeller? What error do you get when you try to initialize?

Maybe you can try to look the regions that the software is trying to create and then indicate just the Hub, Shroud and the blades,not doing the automatic initialization and specifying as 1 passage only.

Did you try something like this?

c120613 July 26, 2012 09:15

I tried exactly like that. I took the subdomains referred to one passage only (inlet, hub, shroud, blade and finally the periodics which you must select in the turboregions without having any error). Although you do not have error the solution is the same as the full annulus one. Does it seem right for you?

Thank you for your collaboration

ismael.s July 26, 2012 09:26

The solution won't change, it should be the same, the only difference is the way you are plotting it.

So it seems right.

Did you create your turbo surface at 0.5 spam without problem?

c120613 July 26, 2012 09:52

Yes, I plotted and I was expecting that the turbosurface was referred only to a single passage, but it consider always the full annulus. Is it possible that I cannot split the information according to the blade passage? So far I used to create table where the number of lines was that of the number of blade. Then along the column I calculated a specific quantity referred to each blade passage. In my case I want a trend referred to each passage. This means that I want per each blade a 1D post-processing (where the dimension involved is for example the radial direction), rather than 0D (when for example you do simply an area or mass flow average).
I do not see why it does not work that. I tried even to submit a request to Ansys, but since yesterday they are not replying.

Thank you for your time, really! I hope you have understood my point and you have the solution in your hands.

Cheers

ismael.s July 26, 2012 12:19

'Yes, I plotted and I was expecting that the turbosurface was referred only to a single passage, but it consider always the full annulus. Is it possible that I cannot split the information according to the blade passage?'

You won't be able to split now, you need to do this at the start in the geometry. You can split the geometry,prepare, run, view results. Viewing the results of a periodic you can fill to "complete" the geometry, I think you cannot do the inverse in CFX post, drawing, preparing and running the 360, then split in the post.

To get information of a single blade, as I understood, would be better to split that fan. Like, I think you have 22 blades, couldn't count well. Get your geometry and split in 22 parts, modeling just one blade and run a periodic simulation, then you will be able to plot 1 blade or the fan.

I have to say, I didn't understand very well what you want to know, but I think you want to plot the information for one blade, right? Streamlines, direction vectors, velocity, velocity in stn frame.

I didn't understand what you mean as 1D and 0D post processing.

I work with pumps and I use do what I told you.

I hope someone can help your better, I guess I did what I could.

:o

ngoc_tran_bao April 26, 2016 03:26

Quote:

Originally Posted by ismael.s (Post 373753)
You won't be able to split now, you need to do this at the start in the geometry. You can split the geometry,prepare, run, view results. Viewing the results of a periodic you can fill to "complete" the geometry, I think you cannot do the inverse in CFX post, drawing, preparing and running the 360, then split in the post.

:o

Hi, my friend. I got a trouble which is exact what you referred to. I have a full geometry of a pump and I can not initialize it in CFX-post. There is always an error like this: "Please verify that the rotation axis and turbo regions are set correctly" even when I set them carefully in previous steps. I am wondering if Turbo Tab only work with periodic geometries, not full geometries? I also try to initialize a periodic example model and it work well. If I am wrong, can you give me some points? Thank you in advance.

-Maxim- April 26, 2016 03:46

Is your rotation axis the z-axis? I know that TurboGrid needs the z-axis as axis of rotation - maybe Turbo in Post needs that as well.
Turbo Tab can work with full geometries - which is bad since we can evaluate single blades anymore - that's what we also discuss here

ngoc_tran_bao April 26, 2016 04:13

Quote:

Originally Posted by -Maxim- (Post 596707)
Is your rotation axis the z-axis? I know that TurboGrid needs the z-axis as axis of rotation - maybe Turbo in Post needs that as well.
Turbo Tab can work with full geometries - which is bad since we can evaluate single blades anymore - that's what we also discuss here

http://imageshack.com/a/img923/7536/JnMLbV.jpg
Yes, the rotation axis is z, as shown on this picture.

-Maxim- April 26, 2016 04:51

sorry I can't help you here any further since I use a "turbo rotation" in PRE and therefore I don't use a real 360 model.
I would try the bruteforce method I no one else can help you: strip down your simulation to only the important parts to make sure that nothing else interferes. Maybe even set up a simplified case. And/or check out the tutorials. Maybe you forgot a simple thing...


All times are GMT -4. The time now is 10:56.