CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

Fine mesh make CFX-Pre react too slow

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By Doginal

Reply
 
LinkBack Thread Tools Display Modes
Old   July 28, 2012, 07:41
Question Fine mesh make CFX-Pre react too slow
  #1
Senior Member
 
Anna Tian's Avatar
 
Meimei Wang
Join Date: Jul 2012
Posts: 473
Rep Power: 6
Anna Tian is on a distinguished road
Hi

When I change coarse mesh to fine mesh, the CFX react very very slow. It even takes a lot time to press a button. But I have to work with fine mesh. May I ask how to solve this problem?

Best regards,
Anna

Last edited by Anna Tian; July 28, 2012 at 08:01.
Anna Tian is offline   Reply With Quote

Old   July 31, 2012, 03:26
Default
  #2
Senior Member
 
Join Date: Jul 2011
Location: Berlin, Germany
Posts: 120
Rep Power: 5
monkey1 is on a distinguished road
The finer the mesh the bigger the files CFX pre has to load and the more Work it has to do...this is kind of normal. But I might guess you could solve your problem partially by getting more RAM.
For example a file with approx. 5.8 Mio Cells consumes around 400 mb RAM (260 MB PreEngine + 140 MB PreGUI_ogl) on my machine. When I load a nearly 15 Mio Cells file it increases to 840 mb RAM (595 MB PreEngine + 235 MB PreGUI_ogl) consumption.
monkey1 is offline   Reply With Quote

Old   July 31, 2012, 06:45
Default
  #3
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 10,662
Rep Power: 84
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
Fine mesh means long run time. That is a fact of life.

So before running a fine mesh simulation:
* Do a sensitivity check to make sure you actually need the fine mesh
* Do all the debugging on a coarse mesh to make sure everything works as expected.

And when you run the big mesh make sure you Use a multi-processor option to speed things up.
ghorrocks is offline   Reply With Quote

Old   August 1, 2012, 14:11
Default
  #4
Member
 
anonymous
Join Date: Jun 2011
Posts: 55
Rep Power: 6
Doginal is on a distinguished road
If your having issues just in pre, along with the idea of doing all your debugging on a course mesh. I dont see any reason why you cant just set up your model in pre using a course mesh then switch to a fine mesh and just update your model with it.
Doginal is offline   Reply With Quote

Old   August 1, 2012, 16:49
Default
  #5
Senior Member
 
Edmund Singer P.E.
Join Date: Aug 2010
Location: Minneapolis, MN
Posts: 470
Rep Power: 10
singer1812 is on a distinguished road
Second what Dog said. Just use a bogus coarse mesh for setup then dump fine mesh in when setup is complete.
singer1812 is offline   Reply With Quote

Old   August 2, 2012, 09:08
Default
  #6
Senior Member
 
Anna Tian's Avatar
 
Meimei Wang
Join Date: Jul 2012
Posts: 473
Rep Power: 6
Anna Tian is on a distinguished road
May I ask what do you mean by using 'multi-processor'? I never heard about that. Does it mean I could use two computers to run my simulation at the same time?
__________________
Best regards,
Meimei
Anna Tian is offline   Reply With Quote

Old   August 2, 2012, 09:30
Default
  #7
Senior Member
 
Join Date: Jul 2011
Location: Berlin, Germany
Posts: 120
Rep Power: 5
monkey1 is on a distinguished road
Not necessarily two (or more) computers. If you have a multicore CPU (e.g: Intel Core i7 Quad or similar) CFX is able to use the 4 (or more) cores for solving instead of doing a single core calculation.
monkey1 is offline   Reply With Quote

Old   August 2, 2012, 12:56
Default
  #8
Member
 
anonymous
Join Date: Jun 2011
Posts: 55
Rep Power: 6
Doginal is on a distinguished road
Quote:
Originally Posted by Anna Tian View Post
May I ask what do you mean by using 'multi-processor'? I never heard about that. Does it mean I could use two computers to run my simulation at the same time?
Ansys by default runs on serial processor setting. As in it will only run off of 1 processor (or 1 processor core).

In the case that you have multiple cores on the processor your using then you can using the MPI Parallel settings when trying to start the simulation to using more processors. Can speed up the run time drastically depending on the model you are running.

The only catch is you need to make sure your licensing can handle it. I believe your license need to enable the MPI setting and also each additional core uses another license.

The setting can be found when defining the run. Using the Platform MPI Local Parallel setting in the run mode option. Then select the number of processors/cores under the partitions setting below the run mode.

The local parallel mode is used when all cores/processors are on the local machine....the distributed i believe is when your are trying to link multiple computers together.

Also as a note to the original topic. If you use a course mesh to define everything in Pre then switch to a fine mesh. Be sure not to change your geometry file at all as you switch meshes. May result in changing some of the names of the geometry features and force you to redefine all your boundries in pre.

good luck

DM
amirhnp likes this.
Doginal is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
No layers in a small gap bobburnquist OpenFOAM Native Meshers: snappyHexMesh and Others 2 November 25, 2012 09:54
snappyHexMesh won't work - zeros everywhere! sc298 OpenFOAM Native Meshers: snappyHexMesh and Others 2 March 27, 2011 21:11
running 2D airfoil mesh in CFX iffy ANSYS 1 February 13, 2011 22:35
CFX Mesh Deformation problem Silmaril CFX 7 October 19, 2010 10:00
OpenFOAM with IBM AIX matthias OpenFOAM Installation 20 March 25, 2008 03:36


All times are GMT -4. The time now is 09:08.