CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

error with isolated volumes in free surface flow

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 31, 2012, 09:46
Default error with isolated volumes in free surface flow
  #1
Member
 
Sara S.
Join Date: May 2010
Location: NJ, USA
Posts: 41
Rep Power: 7
sakalido is on a distinguished road
Hi all,

I am simulating free surface flow in CFX. and I am getting an error message related to isolated volumes and it says:
"If the isolated regions do not have the pressure level set either by the boundary conditions or using a reference pressure equation, you may encounter severe robustness problem. This situation may have arisen because a domain interface was not properly defined during problem set up".

1. I think my initial pressure and initial volume fractions are correct, since I did a very similar simulation before and there was no problems.

2. again I think I am setting my pressure boundaries correctly. A tank is discharging water to a domain. So I have all "wall" and "opening" boundary conditions. "opening" boundary conditions have static pressure (Entrain.) of 0 Pa. and VFair=1 and VFwater=0 in the boundary. It is similar to what I did previously in other simulations.

3. I checked the isolated volume in cfdpost and it's a tank in my geometry which has an opening to the rest of the geometry. when I close this opening I get the "isolated volume" error message and the run stops and creates a *.res file that I can check in cfdpost and when I open this opening, the run doesn't create any *.res file and stops with this error message:
"Error detected by routine PEEKI. CDNAM=/IPHASE, CRESLT=NONE, Current Directory:/FLOW/PHYSICS/ZN1. Stopped in routine MEMERR."
I don't think it is memory related, since I can still run the previous similar simulations with no problem.

4. I had also installed star-CCM+ just before starting this new simulation. I though the licenses may have conflict since they both use similar ports. So I stopped license reading for star-CCM+ as well. Therefore, the problem shouldn't relate to that. Also, again the previous simulations run with no problem. Another evidence that it is not license related.

5. I used a finer grid as well and I still have the same problem. So it's not grid quality.

6. Could it be physics of my problem still? Since it is free surface, my only concern would be initial pressure and volume fraction. But again it is very similar to what I did previously. So I cannot figure out what should be my next step.

Thank you in advance,
Sara
sakalido is offline   Reply With Quote

Old   August 31, 2012, 10:09
Default
  #2
Member
 
Sara S.
Join Date: May 2010
Location: NJ, USA
Posts: 41
Rep Power: 7
sakalido is on a distinguished road
and btw, previously when I had set up wrong initial pressure, I was getting "overflow" error message. This "isolated volume" error message is new and I don't even know, it is really related to pressure setting and problem settings or something else?
sakalido is offline   Reply With Quote

Old   September 1, 2012, 07:30
Default
  #3
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 10,824
Rep Power: 85
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
The error message is clear - you simply have unconnected regions. There is an expert parameter you can use to turn this check off.

Conflicting license ports - you can set the port to be anything you like in flexlm, so just change it to another port. Note you have to change both the license manager server and client.
ghorrocks is offline   Reply With Quote

Old   September 4, 2012, 12:43
Default
  #4
Member
 
Sara S.
Join Date: May 2010
Location: NJ, USA
Posts: 41
Rep Power: 7
sakalido is on a distinguished road
Thank you for the reply Glenn.

The problem is solved.
It was not related to isolated regions.
I had tried setting the expert parameter of "checking the isolated regions" to false but then I was getting "overflow".

As I was suspected the problem was with initial pressure. Free surface flow is very sensitive to the initial conditions.

I modified the initial pressure and it is working now. I have a complex geometry and I am setting initial pressure and volume fraction by using "step" functions. I had a mistake in defining the right height for static pressure.

Thank you for your help again.

Regards,
Sara
sakalido is offline   Reply With Quote

Reply

Tags
cdnam=/iphase, free surface flow, isolated volume, routine peeki

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thermocapillary free surface flow zakifoam OpenFOAM Running, Solving & CFD 6 August 24, 2014 03:24
free surface flow past cylinder vineet FLUENT 1 February 22, 2011 00:11
free surface flow in non-inertial reference frame Tiedingg FLOW-3D 1 February 26, 2009 20:51
Multiphase flow. Dispersed and free surface model Luis CFX 8 May 29, 2007 18:13
Free surface flow simulation question Jane Luo FLUENT 1 April 23, 2004 04:26


All times are GMT -4. The time now is 17:51.