CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

Run-time memory allocation error with 40GB RAM

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   October 11, 2012, 07:52
Default Run-time memory allocation error with 40GB RAM
  #1
New Member
 
Juan Campos
Join Date: Oct 2010
Posts: 12
Rep Power: 6
juanmariacg is on a distinguished road
Hi everybody,

I need your help please!

I'm trying to run an CFX simulation and I always received this:

+--------------------------------------------------------------------+
| Memory Allocated for Run (Actual usage may be less) |
+--------------------------------------------------------------------+

Data Type Kwords Words/Node Words/Elem Kbytes Bytes/Node

Real 1527918.2 453.00 82.17 5968430.5 1812.02
Integer 583426.2 172.98 31.38 2279008.8 691.91
Character 5089.8 1.51 0.27 4970.5 1.51
Logical 96.0 0.03 0.01 375.0 0.11
Double 729.6 0.22 0.04 5700.0 1.73

+--------------------------------------------------------------------+
| ERROR #001100279 has occurred in subroutine ErrAction. |
| Message: |
| *** Run-time memory allocation error *** |
| Not enough free memory is currently available on the system. |
| Could not allocate requested memory - exiting! |
| |
| |
| |
+--------------------------------------------------------------------+


+--------------------------------------------------------------------+
| An error has occurred in cfx5solve: |
| |
| The ANSYS CFX solver exited with return code 2. No results file |
| has been created. |
+--------------------------------------------------------------------+


I know that is a very common issue, but I've red a lot and I don't got it!.

I have 40 GB that should be enoguh, shouldn't be?

thank you in advance!!!
juanmariacg is offline   Reply With Quote

Old   October 11, 2012, 10:01
Default
  #2
Senior Member
 
Join Date: Jul 2011
Location: Berlin, Germany
Posts: 120
Rep Power: 6
monkey1 is on a distinguished road
You have 40 GB of RAM????
Or do you mean Disk Space....
The Memory meant by ANSYS is RAM and not Hard Disk Space...so if you have less than approx. >9GB of RAM it won't work.
monkey1 is offline   Reply With Quote

Old   October 11, 2012, 10:08
Default
  #3
New Member
 
Juan Campos
Join Date: Oct 2010
Posts: 12
Rep Power: 6
juanmariacg is on a distinguished road
thank you!

I mean 40GB or RAM; I had 8GB and I've installed 32GB more.
juanmariacg is offline   Reply With Quote

Old   October 11, 2012, 15:58
Default
  #4
Member
 
Paulo
Join Date: Jun 2011
Posts: 32
Rep Power: 6
strobel is on a distinguished road
Your mesh have high Refinement? maybe your mesh have too many elements per quad.
strobel is offline   Reply With Quote

Old   October 12, 2012, 08:51
Default
  #5
Senior Member
 
Chris DeGroot
Join Date: Nov 2011
Location: Canada
Posts: 387
Rep Power: 6
cdegroot is on a distinguished road
Must be something else going on. Based on the memory allocated table you posted it seems like it is only trying to allocate a bit more than 8GB. So unless you have a lot of other things running, you should have plenty of RAM.
cdegroot is offline   Reply With Quote

Old   October 13, 2012, 03:31
Default
  #6
Senior Member
 
S.Bogoda
Join Date: Jul 2012
Posts: 133
Rep Power: 5
sakurabogoda is on a distinguished road
Are you dealing with steady state or Transient State?
sakurabogoda is offline   Reply With Quote

Old   October 24, 2012, 06:24
Default
  #7
New Member
 
Juan Campos
Join Date: Oct 2010
Posts: 12
Rep Power: 6
juanmariacg is on a distinguished road
I am dealing with steady state,

thank you to everyone
juanmariacg is offline   Reply With Quote

Old   October 24, 2012, 12:53
Default
  #8
Member
 
Paulo
Join Date: Jun 2011
Posts: 32
Rep Power: 6
strobel is on a distinguished road
try change memory allocated factor.
strobel is offline   Reply With Quote

Old   October 24, 2012, 15:58
Default
  #9
New Member
 
Mandeep Singh
Join Date: Oct 2012
Posts: 5
Rep Power: 4
Mandeep is on a distinguished road
I guess mesh is highly refined so try to have mapped mesh or do not use parallel computing


Quote:
Originally Posted by juanmariacg View Post
Hi everybody,

I need your help please!

I'm trying to run an CFX simulation and I always received this:

+--------------------------------------------------------------------+
| Memory Allocated for Run (Actual usage may be less) |
+--------------------------------------------------------------------+

Data Type Kwords Words/Node Words/Elem Kbytes Bytes/Node

Real 1527918.2 453.00 82.17 5968430.5 1812.02
Integer 583426.2 172.98 31.38 2279008.8 691.91
Character 5089.8 1.51 0.27 4970.5 1.51
Logical 96.0 0.03 0.01 375.0 0.11
Double 729.6 0.22 0.04 5700.0 1.73

+--------------------------------------------------------------------+
| ERROR #001100279 has occurred in subroutine ErrAction. |
| Message: |
| *** Run-time memory allocation error *** |
| Not enough free memory is currently available on the system. |
| Could not allocate requested memory - exiting! |
| |
| |
| |
+--------------------------------------------------------------------+


+--------------------------------------------------------------------+
| An error has occurred in cfx5solve: |
| |
| The ANSYS CFX solver exited with return code 2. No results file |
| has been created. |
+--------------------------------------------------------------------+


I know that is a very common issue, but I've red a lot and I don't got it!.

I have 40 GB that should be enoguh, shouldn't be?

thank you in advance!!!
Mandeep is offline   Reply With Quote

Old   October 25, 2012, 03:11
Default
  #10
New Member
 
Holger Dietrich
Join Date: Apr 2011
Location: Germany
Posts: 2
Rep Power: 0
DarylMusashi is on a distinguished road
Hello,

which operating system do you use?

Windows 7 (32 bit) and Windows Vista (32 bit) are able to handle only 4 GB RAM.
2 of these 4 GB RAM can be used for applications. So your 40 GB RAM are worthless, if you use Windows Vista, 7 (or even XP).

If you use Windows:
What you can try is the CFF explorer suite. With this tool you can manipulate program files and allow them to allocate more then 2 GB RAM. Load the particular program file, edit the file header characteristics and enable the option "app can handle > 2 GB of adress space" (see attachment).
You should do a backup copy of your program file before!

If it still does not work - as mentioned before - you can try to play with the solver's memory allocation factor in CFX.

Hope that helps,
Daryl Musashi
Attached Images
File Type: jpg 541ed5b4.jpg (81.4 KB, 25 views)
DarylMusashi is offline   Reply With Quote

Old   October 25, 2012, 05:59
Default
  #11
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 10,954
Rep Power: 85
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
I do not think Daryl's trick will allow you to access >2GB. The CFX code will not have been written to support this so it will not work.

Your choices are:
* Use distributed parallel to split it up over many machines
* Use local parallel to split it up to many processes on the local machine where each process is less than 2GB.
* Move to a 64 bit OS with 64 bit CFX.
* Use a coarser mesh.
ghorrocks is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to write k and epsilon before the abnormal end xiuying OpenFOAM Running, Solving & CFD 8 August 27, 2013 15:33
Extrusion with OpenFoam problem No. Iterations 0 Lord Kelvin OpenFOAM 6 April 12, 2011 11:24
calculation diverge after continue to run zhajingjing OpenFOAM 0 April 28, 2010 04:35
RAM memory problem alpha Main CFD Forum 8 February 12, 2008 12:07
AMG versus ICCG msrinath80 OpenFOAM Running, Solving & CFD 2 November 7, 2006 16:15


All times are GMT -4. The time now is 11:40.