CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   Unexplained Error during Solver Runs (http://www.cfd-online.com/Forums/cfx/108805-unexplained-error-during-solver-runs.html)

cfb November 1, 2012 21:16

Unexplained Error during Solver Runs
 
I'm trying to simulate bubble based flow in columns using CFX. I've been trying to run my simulations but I keep receiving the same error over and over again related to a missing variable that I have been unable to track down. More specifically the error is:

Error in subroutine FNDVAR :
Error finding variable TED_FL2
GETVAR originally called by subroutine cal_COALESCE

I've tried looking through help files, tutorials, online forums but I've not been able to encounter this error or any reasons for it elsewhere. If anyone has any ideas or has experienced this problem before, I would love to hear from them.

The original solver output is pasted below for reference. Thank you for your time and cooperation.


CFD Solver started: Fri Nov 02 06:02:47 2012


+--------------------------------------------------------------------+
| Convergence History |
+--------------------------------------------------------------------+

+--------------------------------------------------------------------+
| Writing transient file 0_full.trn |
| Name : Transient Results 1 |
| Type : Standard |
| Option : Every Timestep |
+--------------------------------------------------------------------+


================================================== ====================
| Timestepping Information |
----------------------------------------------------------------------
| Timestep | RMS Courant Number | Max Courant Number |
+----------------------+----------------------+----------------------+
| 1.0000E-01 | 0.00 | 0.00 |
----------------------------------------------------------------------

================================================== ====================
TIME STEP = 1 SIMULATION TIME = 1.0000E-01 CPU SECONDS = 1.042E+01
----------------------------------------------------------------------
COEFFICIENT LOOP ITERATION = 1 CPU SECONDS = 1.042E+01
----------------------------------------------------------------------
| Equation | Rate | RMS Res | Max Res | Linear Solution |
+----------------------+------+---------+---------+------------------+
| U-Mom-Fluid 1 | 0.00 | 1.2E-04 | 1.2E-03 | 1.8E+00 F |
| V-Mom-Fluid 1 | 0.00 | 6.3E-01 | 7.1E-01 | 1.2E-04 OK|
| W-Mom-Fluid 1 | 0.00 | 1.3E-04 | 1.2E-03 | 1.8E+00 F |
| U-Mom-Air | 0.00 | 1.3E-19 | 1.5E-18 | 3.9E+07 F |
| V-Mom-Air | 0.00 | 1.2E-19 | 1.1E-18 | 2.0E+09 F |
| W-Mom-Air | 0.00 | 1.3E-19 | 1.0E-18 | 3.8E+07 F |
| P-Vol | 0.00 | 3.2E-07 | 7.7E-06 | 42.4 2.0E+00 F |
+----------------------+------+---------+---------+------------------+
| Mass-Fluid 1 | 0.00 | 2.5E-02 | 8.8E-01 | 5.4 8.4E-03 OK|
| Mass-Air | 0.00 | 2.7E-02 | 9.7E-01 | 5.4 7.3E-03 OK|
+----------------------+------+---------+---------+------------------+
----------------------------------
Error in subroutine FNDVAR :
Error finding variable TED_FL2
GETVAR originally called by subroutine cal_COALESCE

+--------------------------------------------------------------------+
| Writing crash recovery file |
+--------------------------------------------------------------------+

+--------------------------------------------------------------------+
| ERROR #001100279 has occurred in subroutine ErrAction. |
| Message: |
| Stopped in routine GV_ERROR |
| |
| |
| |
| |
| |
+--------------------------------------------------------------------+

+--------------------------------------------------------------------+
| An error has occurred in cfx5solve: |
| |
| The ANSYS CFX solver exited with return code 1. No results file |
| has been created. |
+--------------------------------------------------------------------+

End of solution stage.

+--------------------------------------------------------------------+
| The following transient and backup files written by the ANSYS CFX |
| solver have been saved in the directory G:\Bubbles\B&C\bub__004: |
| |
| 0_full.trn |
+--------------------------------------------------------------------+


+--------------------------------------------------------------------+
| Warning! |
| |
| The ANSYS CFX Solver has written a crash recovery file. This file |
| has been saved as G:\Bubbles\B&C\bub__004.res.err and may be an |
| aid to diagnosing the problem or restarting the run. More details |
| should be available in the solver output section of the output |
| file. |
+--------------------------------------------------------------------+


+--------------------------------------------------------------------+
| The following user files have been saved in the directory |
| G:\Bubbles\B&C\bub__004: |
| |
| mon |
+--------------------------------------------------------------------+


This run of the ANSYS CFX Solver has finished.

ghorrocks November 3, 2012 05:42

You have missed a necessary parameter in your set up. My guess is it is something to do with turbulence dissipation. So is your turbulent conditions properly specified? Or some interaction between your bubble coalescence model and turbulence?

cfb November 3, 2012 06:47

Thank you for your reply. I'm using the LES WALE turbulence model but it requires nothing else to be specified in terms of dissipation (as far as my knowledge on the issue goes). Do you have any idea if some coefficient or other such parameter needs to be inserted with LES WALE?
There is another interesting observation I have with regards to this problem. As soon as I turn off the coalescence model, the error repeats for the breakup model. If I turn that off as well, the entire simulation proceeds smoothly. I've checked both these areas for turbulence modelling but have found nothing to go with. Any other ideas :confused:

cfdgremlin November 3, 2012 15:21

The solver is looking for Turbulence Eddy Dissipation in one of the phases but can't find it. Check your turbulence models for each phase.

cal_COALESCE seems to me to be related to MUSIG, so are you trying to run inhomogeneous MUSIG with LES?

CG

cfb November 3, 2012 17:21

@cfdgremlin
 
My turbulence model for water is LES WALE while it is Dispersed Phase Zero Equation for air (bubbles) but I've not specified any parameters for any model at all.
Also, I'm trying to run LES with homogenous MUSIG right now. Plus, where could I get guidelines for Eddy Viscosity Prandtl Number and LES WALE Model Constant?
Thank you for the help cfdgremlin and ghorrocks.

cfb November 3, 2012 17:39

@cfdgremlin
--> I've used a LES WALE Model Constant of 0.325 based on recommendations from:
https://www.sharcnet.ca/Software/Flu.../th/node95.htm

I run the Solver after that and it started iterating though I'm not done with the complete iteration as yet. This seems to have relieved the issue but I would really appreciate if you could please comment on the use of this constant value given water bubble flow in a homogeneous MUSIG regime. Thank you.

cfdgremlin November 9, 2012 16:42

Hi cfb,

sorry, but I'm not an LES or MUSIG expert so I can't offer any advice on the parameters. However, I'm surprised you managed to get the case going by simply modifying/adding the constant, because as Glenn pointed out the initial error is due to a problem with general physics setup.

All the best,

CG


All times are GMT -4. The time now is 23:32.