CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   Using Workbench, CFX-Pre doesn't update mesh from upstream data (http://www.cfd-online.com/Forums/cfx/109739-using-workbench-cfx-pre-doesnt-update-mesh-upstream-data.html)

Shawn_A November 25, 2012 12:40

Using Workbench, CFX-Pre doesn't update mesh from upstream data
 
I'm using Workbench to setup my CFX project so I've started with on CFX item. Since my mesh is similar for all cases, just different aspect ratios, and the boundary conditions are the same, I've duplicated the CFX item for as many ARs as I have. I've updated the geometry and update the mesh for each case, but for some reason the updated mesh doesn't get brought fordward into CFX-Pre - I'm still getting original mesh - even if I update or edit the CFX cell.

I can reset the CFX cell, edit it which brings in the correct mesh, and then manually set all my conditions and boundaries again. I can reset the CFX cell, edit it which brings in the correct mesh and import my original case and delete some things. I can import the update mesh manually without resetting the CFX cel, delete the original mesh and reapply boundaries to the new mesh. Or....

Is there something I'm missing so that CFX will automatically update my mesh from the upstream mesh? I haven't had this issue before, so I'm thinking maybe it's a setting that's changed?

Thanks :)

Shawn_A November 25, 2012 13:06

I should also add that I'm using V14. And, when I modify my mesh, the status of the CFX cell does change to indicate that it is out of date and needs to be updated.

I tried importing the mesh manually without resetting the CFX cell. This will not work because I cannot delete the original mesh.

Shawn_A November 25, 2012 14:06

I found a "Reload Mesh Files" command available in CFX-Pre standalone. This is the feature to perform the task I'm looking for, however, there is a note at the bottom of the page which reads "This feature is not required (and is not available) in CFX-Pre launched from ANSYS Workbench." It would appear as though this feature is not working properly, or, it somehow got linked incorrectly. Any ideas how to re-enable it or re-link it correctly?

Also, I can perform an Export CCL command which will export my CFX setup minus the mesh (time settings, boundaries, monitor points, etc.). This seemed to work fine. I did have to redo my mesh transformations but after that all the conditions were good.


All times are GMT -4. The time now is 12:16.