CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   error reported in cfx-solver (http://www.cfd-online.com/Forums/cfx/110340-error-reported-cfx-solver.html)

TallesC December 8, 2012 19:33

error reported in cfx-solver
 
Interpolating Onto Domain "camara"
================================================== ====================

Total Number of Nodes in the Target Domain = 362488
Bounding Box Volume of the Target Mesh = 2.53598E+02


Checking all source domains from the source file:
Target mesh is the same as domain "camara".

Start direct copying of variables from domain "camara".

+--------------------------------------------------------------------+
| Variable Range Information |
+--------------------------------------------------------------------+
+--------------------------------------------------------------------+
| Variable Name | min | max |
+--------------------------------------------------------------------+

+--------------------------------------------------------------------+
| ****** Notice ****** |
| |
| There are no variables for interpolation from the source domain. |
| Please check the source file carefully. |
+--------------------------------------------------------------------+


Details of error:-
Details of error:-
----------------
----------------
Error detected by routine MAKDAT
Error detected by routine MAKDAT
Illegal data area length CDANAM = NCOMPT CDTYPE = INTR ISIZE = 0
Illegal data area length CDANAM = NCOMPT CDTYPE = INTR ISIZE = 0
CRESLT = SIZE
CRESLT = SIZE


Current Directory : /INTERP/SOLUTION/DST/VX
Current Directory : /INTERP/SOLUTION/DST/VX

+================================================= ===================+
| ****** PROBLEM REPORT ****** |
|--------------------------------------------------------------------|
| Subsystem: Input and Output |
| Subroutine name: ErrAction |
| Severity level: Fatal Error |
| Error message number: 001100279 |
|--------------------------------------------------------------------|
| Message: |
| |
| Stopped in routine MEMERR |
| |
| |
| |
| |
| |
+================================================= ===================+

+--------------------------------------------------------------------+
| An error has occurred in cfx5solve: |
| |
| Error interpolating results onto the new mesh: C:\Program |
| Files\ANSYS Inc\v130\CFX\bin\winnt-amd64\solver-hpmpi.exe exited |
| with return code 1. |
+--------------------------------------------------------------------+


+--------------------------------------------------------------------+
| The following user files have been saved in the directory |
| C:/Users/Administrador/AppData/Local/Temp/2/Forno_EDC_3624_Workin- |
| g/dp0/CFX/CFX/Work1/Fluid Flow CFX_007: |
| |
| job |
+--------------------------------------------------------------------+


This run of the ANSYS CFX Solver has finished.


Please help with this problem????

cdegroot December 9, 2012 01:14

Looks like the file you are trying to use to interpolate your initial condition from is not suitable. It seems to be missing required variables. Check that the file you are using is suitable for the case you are trying to run and has all required variables.

TallesC December 9, 2012 12:20

how exactly do I do this?

cdegroot December 9, 2012 12:25

Where did the file that you are using come from? From a previous run? Did you solve for all of the same variables?

I may be helpful to describe the problem you are trying to solve and the approach you have taken so far.

TallesC December 9, 2012 14:32

is this simulation consists of a flow of hot air in a box which has a pipe as a coil, when the two ran together (coil and box) was giving problem then separated the geometry, coil ran successfully, but the box is presenting this error, I'm thinking it may be the mesh that is not good, what do you think?, those variables that you say are the CFX-pre??

ghorrocks December 9, 2012 17:07

The problem is not mesh quality. Well, at least not yet. As Chris said previously it appears to be looking for a variable in the initial value file which is not there.

So if you are running a multi domain problem from an initial condition where only one domain was modelled I think that is your problem. You will have to specify initial conditions for the domain which was not previously modelled.

TallesC December 9, 2012 20:00

Glen I understand what you said, but there is only one field because I pulled the pipe inner box, warm air enters through holes in the box sides and exits through a hole on top of the box, I'm not seeing the problem with this variable initial all entries in cfx were pre-specified!

ghorrocks December 9, 2012 20:17

It has been a while since I have done this but I do recall problems using an initial condition which does not specify all domains in a model. If you just do an interpolation some domains are not defined and if you specify an initial condition in CFX-Pre you do not get the interpolated intial results. This may have been improved with recent releases but I recall somehow setting all initial conditions (can't remember how, either a short dummy run or an CFX-Pre) and then interpolating the initial condition results over the top of that, which leaves the initial condition not defined in the initial file as the previous initial condition.

TallesC December 9, 2012 20:40

I do not understand what that message meant, what are those variables that are mentioned?

There are no variables for interpolation from the source domain. |
| Please check the source file carefully.


All times are GMT -4. The time now is 04:14.