CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   RSH problem for parallel running in CFX (http://www.cfd-online.com/Forums/cfx/11187-rsh-problem-parallel-running-cfx.html)

Nicola April 7, 2006 09:52

RSH problem for parallel running in CFX
 
Hi, I cannot lunch in parallel with CFX on 2 pc. I edit hosts.ccl file in this way:

EXECUTION CONTROL: PARALLEL HOST LIBRARY: HOST DEFINITION: master

Installation Root = C:\Programmi\ANSYS Inc\CFX\CFX-%v

Host Architecture String = intel_xeon64.sse2_winnt5.1 END # HOST DEFINITION master

HOST DEFINITION: slave

Installation Root = C:\Programmi\ANSYS Inc\CFX\CFX-%v

Host Architecture String = intel_xeon64.sse2_winnt5.1 END # HOST DEFINITION slave END # PARALLEL HOST LIBRARY END # EXECUTION CONTROL

When I lunch CFX solver I have this message:

An error has occurred in cfx5solve:

Remote connection to slave exited with return code 1. It gave the following output:

rsh: impossibile stabilire la connessione

> slave.xxx.it:Connessione rifiutata

Check that you have typed the hostname correctly, that you have an account "Master" on the specified host with permission to rsh from this host, and that (particularly for Windows hosts) it is running an rsh daemon. You can use the following command to check the connection to a UNIX machine:

rsh slave uname

or the following command if it is a Windows machine:

rsh slave cmd /c echo working

The hostname is correct! Where is the problem? Thank you

JACZ November 25, 2010 22:20

Hi Nicola
Probalbly you solved the problem at this date. But today I was at the same point with windows 7 32 bits, I found that the rsh service didnt start in auto, so i started manually (and left it in auto) from the control panel> Administrative Tools > services > remote services host (? or something like that) and star it.

but before this, I used the comand
rshd -remove
and after
rshd -install
in the folder (msdos) winnt

Afer try in ms dos
rsh "hostname the same pc or the other pc conected" cmd /c echo working
if rsh is working you ill see the word working in the following line.

Note that rsh service must be running on all machines.

I disabled the windows firewall in all the machines
Now is running

I hope to be usefull

marceloguerra1 June 15, 2012 12:33

I having a similar problem, but when I tried what JACS said I have the following problem:

C:\Windows\rsh>rsh host cmd /c echo working
cannot log in as local user 'cfxuser', remote user 'cfxuser'
Permission denied by rshd

Could anyone help me to solve this problem?

Thanks!!

ghorrocks June 17, 2012 19:22

Check you do not have a firewall blocking the rsh port, or your IT department have put restrictions on RSH.

marceloguerra1 June 18, 2012 07:09

ghorrocks, thanks for you reply, but i tried to turn off the firewall in two computers and it doesn't solved my problem.

The error in cfx that i having the problem is:

+--------------------------------------------------------------------+
| An error has occurred in cfx5solve: |
| |
| Remote connection to engenhariasrv could not be started: Unable to |
| execute rsh: An operation was attempted on something that is not a |
| socket. Check that you have typed the hostname correctly, that you |
| have an account "guerra" on the specified host with permission to |
| rsh from this host, and that (particularly for Windows hosts) it |
| is running an rsh daemon. You can use the following command to |
| check the connection to a UNIX machine: |
| |
| rsh engenhariasrv uname |
| |
| or the following command if it is a Windows machine: |
| |
| rsh engenhariasrv cmd /c echo working |
+--------------------------------------------------------------------+

ghorrocks June 18, 2012 18:31

There is a detailed setup guide and check in the CFX documentation for parallel setup. Have you gone through that?


All times are GMT -4. The time now is 06:07.