CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

RSH problem for parallel running in CFX

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 7, 2006, 09:52
Default RSH problem for parallel running in CFX
  #1
Nicola
Guest
 
Posts: n/a
Hi, I cannot lunch in parallel with CFX on 2 pc. I edit hosts.ccl file in this way:

EXECUTION CONTROL: PARALLEL HOST LIBRARY: HOST DEFINITION: master

Installation Root = C:\Programmi\ANSYS Inc\CFX\CFX-%v

Host Architecture String = intel_xeon64.sse2_winnt5.1 END # HOST DEFINITION master

HOST DEFINITION: slave

Installation Root = C:\Programmi\ANSYS Inc\CFX\CFX-%v

Host Architecture String = intel_xeon64.sse2_winnt5.1 END # HOST DEFINITION slave END # PARALLEL HOST LIBRARY END # EXECUTION CONTROL

When I lunch CFX solver I have this message:

An error has occurred in cfx5solve:

Remote connection to slave exited with return code 1. It gave the following output:

rsh: impossibile stabilire la connessione

> slave.xxx.it:Connessione rifiutata

Check that you have typed the hostname correctly, that you have an account "Master" on the specified host with permission to rsh from this host, and that (particularly for Windows hosts) it is running an rsh daemon. You can use the following command to check the connection to a UNIX machine:

rsh slave uname

or the following command if it is a Windows machine:

rsh slave cmd /c echo working

The hostname is correct! Where is the problem? Thank you
  Reply With Quote

Old   November 25, 2010, 22:20
Smile
  #2
New Member
 
J_A
Join Date: Feb 2010
Posts: 7
Rep Power: 7
JACZ is on a distinguished road
Hi Nicola
Probalbly you solved the problem at this date. But today I was at the same point with windows 7 32 bits, I found that the rsh service didnt start in auto, so i started manually (and left it in auto) from the control panel> Administrative Tools > services > remote services host (? or something like that) and star it.

but before this, I used the comand
rshd -remove
and after
rshd -install
in the folder (msdos) winnt

Afer try in ms dos
rsh "hostname the same pc or the other pc conected" cmd /c echo working
if rsh is working you ill see the word working in the following line.

Note that rsh service must be running on all machines.

I disabled the windows firewall in all the machines
Now is running

I hope to be usefull
JACZ is offline   Reply With Quote

Old   June 15, 2012, 12:33
Default
  #3
New Member
 
Marcelo Guerra
Join Date: May 2012
Posts: 3
Rep Power: 5
marceloguerra1 is on a distinguished road
I having a similar problem, but when I tried what JACS said I have the following problem:

C:\Windows\rsh>rsh host cmd /c echo working
cannot log in as local user 'cfxuser', remote user 'cfxuser'
Permission denied by rshd

Could anyone help me to solve this problem?

Thanks!!
marceloguerra1 is offline   Reply With Quote

Old   June 17, 2012, 19:22
Default
  #4
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 10,832
Rep Power: 85
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
Check you do not have a firewall blocking the rsh port, or your IT department have put restrictions on RSH.
ghorrocks is offline   Reply With Quote

Old   June 18, 2012, 07:09
Default
  #5
New Member
 
Marcelo Guerra
Join Date: May 2012
Posts: 3
Rep Power: 5
marceloguerra1 is on a distinguished road
ghorrocks, thanks for you reply, but i tried to turn off the firewall in two computers and it doesn't solved my problem.

The error in cfx that i having the problem is:

+--------------------------------------------------------------------+
| An error has occurred in cfx5solve: |
| |
| Remote connection to engenhariasrv could not be started: Unable to |
| execute rsh: An operation was attempted on something that is not a |
| socket. Check that you have typed the hostname correctly, that you |
| have an account "guerra" on the specified host with permission to |
| rsh from this host, and that (particularly for Windows hosts) it |
| is running an rsh daemon. You can use the following command to |
| check the connection to a UNIX machine: |
| |
| rsh engenhariasrv uname |
| |
| or the following command if it is a Windows machine: |
| |
| rsh engenhariasrv cmd /c echo working |
+--------------------------------------------------------------------+
marceloguerra1 is offline   Reply With Quote

Old   June 18, 2012, 18:31
Default
  #6
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 10,832
Rep Power: 85
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
There is a detailed setup guide and check in the CFX documentation for parallel setup. Have you gone through that?
ghorrocks is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ansys 13 CFX problem on LInux Opensuse 11.4 serendipity CFX 10 August 7, 2012 03:24
Ansys Workbench (CFX) bucket problem njsavage CFX 1 April 30, 2009 09:51
Ansys CFX bucket problem njsavage Main CFD Forum 1 April 30, 2009 09:48
Workbench (CFX) bucket problem njsavage ANSYS 0 April 29, 2009 17:10
Problem with viewing graphic view when running in UNIX pitisrisuk Main CFD Forum 0 April 18, 2009 21:39


All times are GMT -4. The time now is 09:22.