CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   Problem in initializing transient simulation with a finer mesh (http://www.cfd-online.com/Forums/cfx/116572-problem-initializing-transient-simulation-finer-mesh.html)

sidd April 22, 2013 11:48

Problem in initializing transient simulation with a finer mesh
 
2 Attachment(s)
Hello,

I am trying to initialize a transient simulation in CFX 14.5. The domain represents a nuclear fuel pin with wire spacers.

I run a steady state simulation (inlet outlet BCs) with around 4 hundred thousand nodes. I get the steady simulation results file and initialize the same mesh transient simulation (periodic BCs). It runs fine. (See Attachments)

Next I refine that mesh to a 3 million node mesh and then follow the same procedure: Get a steady state results file to initialize a transient simulation. For some reason, this does not work! My velocity goes to near zero in the mean flow at the very first time step of the transient simulation. (See Attachments)

I have the same setup and everything. The only thing I change is that I scale my mesh in ICEM to a higher node code.

I don't know what I am doing wrong, but this does not make sense to me.

P.S.: Even if I initialize with a csv file, it doesn't work.

Thanks,
Mustafa

ghorrocks April 22, 2013 18:31

Looks like a problem with interpolation of the initial conditions onto the fine mesh.

The output file contains some information about the interpolation process at the start. Can you post this?

You might have to manually interpolate the initial condition using the command line cfx5interp. This will give you more control about what is goign on and hopefully a path to fix it.

sidd April 23, 2013 11:29

2 Attachment(s)
Hello Ghorrocks,

I tried to look at the interpolation information and other information in the two files, but they look very "similar" to me.

I am attaching two output files with this message. You might notice that the one that works has a mesh of 2.4 million nodes, while the other that does not work has 2.8 million nodes.

I am guessing it is not a mesh problem. If it was a mesh problem, I would see regions of unrealistic behavior, but here the whole domain seems to have almost zero velocity. Am I right in thinking this way?

Thanks

singer1812 April 23, 2013 17:04

Umm. Your GGI isnt set right on your 2.8M element case.

2.8M case (no connection):

Domain Interface Name : Domain Interface 1

Discretization type = GGI
Intersection type = Direct
Non-overlap area fraction on side 1 = 1.00E+00
Non-overlap area fraction on side 2 = 1.00E+00

2.4M case (connection):

Domain Interface Name : Domain Interface 1

Discretization type = GGI
Intersection type = Partitioner
Non-overlap area fraction on side 1 = 0.00E+00
Non-overlap area fraction on side 2 = 0.00E+00


Might want to fix that.

sidd April 24, 2013 20:41

Hi Singer and Ghorrocks,

I think I have got something. I think it is a mesh problem.

You can see me domain in the attachments with the first post. If you look carefully in the fine mesh case in Figure 2, you will see a black line that follows the pin axially and this line is not present in the coarse mesh case.

So what was happening was that the fine mesh had automatically created a region called Primitive 2D for some reason. And due to that it was not initializing properly.

I will run some more tests to confirm this and explain what I am talking about.

It's quite late here now.

Thanks,
Mustafa

sidd May 2, 2013 12:29

2 Attachment(s)
Hello,

Sorry for the late response. So I figured out the problem and fixed it. Take a look at the two attachments and it explains that there was some mesh error that was causing the problem. You can see that the mesh looks fine in ICEM, but when it is imported into CFX, you find an extra region in the mesh.

As a reminder: I was trying to initialize a transient simulation with some data, but it worked for a coarse mesh but not for a fine mesh.

How did I fix it? I just reduced some nodes in the region where that "Primitive 2D region" was appearing.

Why was the software doing it? I am not quite sure about it. Maybe I could ask this question in the ICEM forum that the mesh looks fine in ICEM but adds an extra part in CFX.

Thanks,
Mustafa

venkatesh92 April 1, 2015 16:41

Hi,

I am not sure if you sorted this problem out! But my best guess is that an edge was not suppressed in the geometry and it shows up in fluent as a weird solid body. It is best to suppress all the edges/faces in the geometry and leave the solid body alone for the mesher to handle!


All times are GMT -4. The time now is 20:36.