CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

memory problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 5, 2014, 02:54
Post memory problem
  #1
New Member
 
AKHILESH S L
Join Date: Sep 2013
Location: Trivandrum
Posts: 29
Rep Power: 3
AKHILESH S L is on a distinguished road
hi everyone,
i am running cfx in our workstation having 64gb ram and 500 GB hard disc. rest of hdd memory is using foe rid backup. i am running a cfx with 5crore elements. but in each solution it is showing that "run time memory allocation error. not enough memory is available in your system". i am searching the solution for too many days. i have already read almost all the thread about memory in cfx forum. but i am not getting a solution. what may be problem friends? please help me. this 5crore is not a problem for a 65gb workstation having 12cores and using windows 7 64 bit. any help from anybody is appreciable. this is the last hope for my problem
AKHILESH S L is offline   Reply With Quote

Old   February 5, 2014, 06:24
Default
  #2
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 10,800
Rep Power: 85
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
The message means exactly what is says - you have run out of memory on your machine. Some possibilities are:
1) You have other applications running which means CFX cannot get the 64GB.
2) You have a 32 bit OS installed - check that you really do have a 64 bit OS.
3) You have the 32 bit version of CFX installed - then uninstall it and install the 64 bit version.
ghorrocks is offline   Reply With Quote

Old   February 5, 2014, 12:47
Post
  #3
New Member
 
AKHILESH S L
Join Date: Sep 2013
Location: Trivandrum
Posts: 29
Rep Power: 3
AKHILESH S L is on a distinguished road
THANK YOU ghorrocks
I HAVE CHECKED THESE SOLUTIONS MANY TIMES.
no other applications are running in my workstation and my workstation is installed with a 64bit windows 7 and Ansys is also 64 bit version. what should i do to rectify this problem?
AKHILESH S L is offline   Reply With Quote

Old   February 5, 2014, 12:53
Default
  #4
Member
 
Join Date: Nov 2011
Location: Germany
Posts: 40
Rep Power: 5
TrII4d is on a distinguished road
hi AKHILESH S L,

try the following:
when u are in CFX-solver manager and the "Define Run" window appears select "Show Advanced Controls" in "Run Definition" ... after that u can go to "Partitioner" and there you can enter a value in the field "Memory Alloc Factor" ... the standard value is 1.0 ... increase this number with 1.2 or 1.4 ... after that u have to select "Detailed Memory Overrides" ... there u have to enter the same value in the field "Real Memory" ... but do NOT forget the suffix "x" i.e. 1.2x or 1.4x ... after that u can start the run ... maybe its better if u try 8 cores in a first run ...

good luck
TrII4d is offline   Reply With Quote

Old   February 5, 2014, 13:02
Post
  #5
New Member
 
AKHILESH S L
Join Date: Sep 2013
Location: Trivandrum
Posts: 29
Rep Power: 3
AKHILESH S L is on a distinguished road
THANK YOU TrII4d
thank you very much for spending your valuable time for this detailed reply. this is the first time i am getting a reply with a positive feeling. i will try this solution and let you know whether it works or not. thank you once again from the bottom of my heart.
AKHILESH S L is offline   Reply With Quote

Old   February 5, 2014, 13:04
Default
  #6
Member
 
Join Date: Nov 2011
Location: Germany
Posts: 40
Rep Power: 5
TrII4d is on a distinguished road
you are welcome ... i hope this works ... if not ... do not hesitate to ask ...

by the way ... trivandrum is a nice place ... i visited it last year ... great temple
TrII4d is offline   Reply With Quote

Old   February 5, 2014, 17:46
Default
  #7
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 10,800
Rep Power: 85
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
At what stage of the solution do you get the memory error? (Pre-processor, partitioning, solving, post-processing?)

How big is the simulation you are running?

How are you running it? Single processor? Multiprocessor? (then how many processes?)
ghorrocks is offline   Reply With Quote

Old   February 6, 2014, 01:50
Smile
  #8
New Member
 
AKHILESH S L
Join Date: Sep 2013
Location: Trivandrum
Posts: 29
Rep Power: 3
AKHILESH S L is on a distinguished road
thank you TrII4d
it worked... thanks a lot my dear friend. it is now running smoothly. thank you from the bottom of my heart. by the way you are always welcome to Trivandrum....god's own place...
AKHILESH S L is offline   Reply With Quote

Old   February 6, 2014, 01:52
Post
  #9
New Member
 
AKHILESH S L
Join Date: Sep 2013
Location: Trivandrum
Posts: 29
Rep Power: 3
AKHILESH S L is on a distinguished road
dear ghorrocks
the error appeared in the solving stage only. now it got solved. running in local parallel 4 cores. total 2crore elements are there. thank you very much for your reply.
AKHILESH S L is offline   Reply With Quote

Reply

Tags
memory allocation factor, memory error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Paraview 3.12 memory allocation problem while saving animation jgomez OpenFOAM Paraview & paraFoam 17 September 14, 2013 17:03
combustion problem mcnair CFX 9 March 22, 2011 15:06
RAM memory problem alpha Main CFD Forum 8 February 12, 2008 12:07
memory problem Matt FLUENT 1 October 1, 2006 18:24
"Memory too low" problem with Fluent HELP NEEDED Amr FLUENT 6 May 8, 2006 12:06


All times are GMT -4. The time now is 03:38.