CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   insufficient character work space (http://www.cfd-online.com/Forums/cfx/18389-insufficient-character-work-space.html)

Annie September 10, 2000 18:21

insufficient character work space
 
Hi,

I am using cfx4.2 to simulate partical transport in a mixing chamber. Before it, I have successfully got the result of velocity and temperture, I keep the physical model unchanged, only modify the Command file to solve for partical transport (only one partical from inlet), however, it always shows the error "Insufficient Character work space, Required is 2390238, available is 23842), what is the problem of it? what can I do with it? Please give you suggestion.

Thanks in advance,

Annie

Jan Rusås September 11, 2000 03:14

Re: insufficient character work space
 
Look in the manual!

If you look in the index of the solver manual under workspace you will be guided to the correct section § 3.2.1. You have to set the limits for you problem, including particles increases the need for work space allocations.

Regards Jan

Annie September 11, 2000 15:17

Re: insufficient character work space
 
Thanks Jan,

I tried to set the problem size as 'Large', but the largest character work space can't meet my requirement yet. the largest is 100000, but I need nearly 2400000.

Is it possible that I made some mistakes in command file that made the character work space so big?

Thanks for your advice,

Sincerely,

Annie.

Jan Rusås September 11, 2000 17:01

Re: insufficient character work space
 
Hi Annie,

You can set the different limits manually to any size.

I do not remember the typical limits when dealing with particles and I dont have acces to my old files right now, but I recall that in cases with particles or radiation that it was neccesary to set the limits manually. I very rarely use the large,medium or small options in the command file, I do as you partly have done, looks in the output file to see the required limits and then set those manually (copy paste from old files or through enviroment) plus, say 10-20%.

Hope it helps

Regards Jan,



All times are GMT -4. The time now is 14:24.