CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

IPALL giving NULL values

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 29, 2001, 11:51
Default IPALL giving NULL values
  #1
cfd guy
Guest
 
Posts: n/a
Hi everybody,
I know there may be time consuming for you to read this post but, here I go.
Have anyone ever noticed a possible fail in the IPALL utility routine in CFX-4? I'm meaning this because I defined a region (USER2D), which is located exactly in an interblock boundary, in CFX-BUILD, and when I submit the job using USRTRN, in the output file I got null values of every properties I want to print in that region [i.e U(INODE,1)=V(INODE,1)=W(INODE,1)=P(INODE,1)=0.000, where 1 is my default phase, air]. I'm running two cases with two different geometry and is a gas-solid flow with a grid containing less than 12k cells.
The funny part is, some days ago I did the same thing with another grid and did work very well, I could obtain every property I wanted, but now I'm not able to extract the information recquired. And another thing, when I check those values, IPALL gives me correct AREA without giving me the correct values. My utility routine is showed below, it is an area weighted average pressure of phase 1 (my example was extracted and changed from the manual).


CALL IPALL('USER2D-P0','*','PATCH','CENTRES',IPT,NPT,CWORK ,IWORK)
PSUM = 0.
DO 201 I=1,NPT
INODE=IPT(I)
IBDRY=INODE-NCELL
IFACE=IPFACB(IBDRY)
AREAM=SQRT(AREA(IFACE,1)**2+AREA(IFACE,2)**2+AREA( IFACE,3)**2)
TAREA=TAREA+AREAM
PSUM=PSUM+P(INODE,1)*AREAM
201 CONTINUE
USP0 = PSUM/TAREA/1.E+05

As I said, IPALL prints the correct total area on my USER2D (TAREA variable) and if I put a write(6,*) in the loop's middle, every property has null value. I have checked and changed several things in the fortran file and the grid, but I could not obtain any success.
Sorry for the long message, but any suggestions will be really appreciated.
Kind regards,
cfd guy
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
TimeVaryingMappedFixedValue irishdave OpenFOAM Running, Solving & CFD 26 July 24, 2014 05:30
Why is my fluent simulation giving Cp values above 1??? wils Main CFD Forum 3 March 26, 2010 11:12
max node values exceed max element values in contour plot jason_t FLUENT 0 August 19, 2009 12:32
exact face values RubenG Main CFD Forum 0 June 22, 2009 12:09
strange node values @ solid/fluid interface - help JB FLUENT 2 November 1, 2008 14:04


All times are GMT -4. The time now is 04:45.