CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   CFX 5.5 fails to start from an interpolation (http://www.cfd-online.com/Forums/cfx/18857-cfx-5-5-fails-start-interpolation.html)

Astrid March 6, 2002 20:58

CFX 5.5 fails to start from an interpolation
 
Hi All,

I can easliy interpolate a converged solution from a rough mesh on a new refined mesh in CFX-5.5. However, when I start to solve the refined mesh, I get numerous upper and lower limits and a maximum Mach number ranging from 20-370 after the first iteration. After the second iteration I get an ENFORCE_BOUNDS ERROR and the simulations ends. This applies for an ideal gas case with v = 10 m/s, nothing difficult though. Of course I have switch Smart Start off.

What am I doing wrong? Did I forget something? Does anyone have a clue? In CFX 5.4.1 restarting from an interpolation worked perfectly.

Help....... Astrid

Neale March 7, 2002 14:41

Re: CFX 5.5 fails to start from an interpolation
 
Sounds nasty. Maybe something got screwed up by the interpolation. Did you try looking at the interpolated results in Post to see if they look alright?

You must be using expressions for Cp and so on to get lower and upper bounds errors. Does the same thing happen if you set a constant Cp? Which variable does enforce bounds stop on?

Neale

Astrid March 7, 2002 18:26

Re: CFX 5.5 fails to start from an interpolation
 
Dear Neale,

Yes, I have checked the interpolated result in CFX-Post and this looks perfect.

Yes, I use expressions for Cp. I have set Cp constant after interpolation but that didn't help.

Moreover, I have performed the following check. I have interpolated a solution from a coarse mesh ON THE SAME COARSE MESH in the original definition file. This works perfectly!!!!! So, I think that solving with a interpolated solution on different (refined) mesh does not work.

Any comment? Astrid

Sjoerd Romkes March 8, 2002 12:31

Re: CFX 5.5 fails to start from an interpolation
 
Hi Astrid,

Just a question... did you install the solver patch for CFX-5.5 of 29th January 2002? Maybe this fixes the problem...

In the list of bugs, I saw: "A fatal error on restart was reported when Cp was defined as a function of temperature via CEL expression, under certain conditions, causing a fatal error message indicating "data table out of bounds". "

You can find the patches by logging into the community pages at http://www.software.aeat.com/cfxcommunity You will be prompted for usr and pwd.

I was getting crazy of a -what I found out later- bug in the multiphase Gidaspow model which was fixed in the bug. Now I am happy, hope you get happy soon.

Regards, Sjoerd

Astrid March 11, 2002 07:16

Re: CFX 5.5 fails to start from an interpolation
 
Sjoerd,

Thanks for the hint but the patch did not help.

Astrid


Neale March 13, 2002 03:15

Re: CFX 5.5 fails to start from an interpolation
 
I suggest you send your problem into your service rep to have a look. It's tough to diagnose whats going on in this forum.

Neale.

Neale March 13, 2002 03:23

Re: CFX 5.5 fails to start from an interpolation
 
I was wondering if you tried resetting the temperature initial guess. Set it to Value rather than Automatic with Value.

Neale.

Astrid March 16, 2002 17:20

Re: CFX 5.5 fails to start from an interpolation
 
Hoi Sjoerd,

Thanks for the hint. Sometimes the patch helps, sometimes it doesn't. I haven't found the trigger yet. I will let you know when I have.

Astrid


All times are GMT -4. The time now is 19:58.