CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   meshing (http://www.cfd-online.com/Forums/cfx/19541-meshing.html)

strudl March 28, 2003 18:08

meshing
 
I am trying to mesh in CFX-BUILD, but keeps getting small internal angle error, what is the way to solve the problem

Glenn Horrocks March 30, 2003 18:23

Re: meshing
 
Hi Strudl,

Usually the small internal angle message is a warning, not an error so you can still continue (but probably with a pretty horrible mesh). Possible ways of improving the situation are: 1) Merge all the offending surfaces together using the surface editor, 2) Remove the sliver surfaces using the surface editor, 3) Use a finer mesh, 4) Reconstruct the geometry without the nasty surface.

Some combination of the above approaches usually does the trick.

Regards, Glenn Horrocks

Dany March 30, 2003 22:13

Re: meshing
 
Hi,

I have one question regarding the meshing as well. Hopefully you could share a bit of your experience with me.

The mesh I generated in Build tends to gather at the corner of the curved surface and when you refine the mesh, you will refine those elements, which doesn't serve much effect to the solution (since they're already small enough if compared to other elements on the surface)

Anyone has any idea of how to avoid refining the mesh elements at the corner in the mesh refinement process?

Thanks, Dany

Helper March 31, 2003 05:59

Re: meshing
 
Are you refining the mesh using adaption after solving or are you asking why you get a fine mesh where the geometry is curved? If it is the latter try setting the minimum edge length on the angular resolution panel to something slightly bigger.

Dany March 31, 2003 09:25

Re: meshing
 
Thanks, Helper. You're answering my question again.

I wonder if it is possible to get a more uniform mesh (like what we have in structured hex mesh) in the Build? Anyway, I will try your suggestion now.:)

Hope that you don't mind answering my questions. Thousands thanks.

strudl March 31, 2003 15:32

Re: meshing
 
I prefer options 2 and 3 in that order, could you be more specific on how to remove the sliver ? also Build limits to a certain extent the size of my mesh. Thanks

Glenn Horrocks March 31, 2003 18:13

Re: meshing
 
Hi strudl,

The surface editor is discussed in the on-line documentation. Look it up in the master index. Also, tutorial 17 uses the surface editor to remove sliver surfaces.

Regards, Glenn

Bob April 2, 2003 08:39

Re: meshing
 
Danny, I have found the same thing happpened on a pipe geometry that was defined as a single surface and the angular resolution was turned on in the meshing stage. I got around the problem by turning off angular resolution and just using a line mesh control (or even a surface mesh control). This was not an ideal solution but my geometry was simple. I'd try what Helper suggested first.

Dany April 2, 2003 09:54

Re: meshing
 
Hi, Bob. My geometry is quite complex since the cross section is changing & it consists of multiple curved surfaces. My colleague is working on the simpler geometry but even so he still get a poor mesh along the curved surface.

I did use the surface mesh control. However, it doesn't really improve the mesh quality if you don't set it small enough. Besides, I don't think it's actually making the situation better as you still get the error message in the mesh adaption process. I'm not saying this problem can't be solved in CFX5 but you may need lots of experience to know the tricks. Thus, I don't think the current version is user friendly for the begineer. We are now looking for other meshing tool and hopefully it will give us better results. Good luck.

Helper April 3, 2003 06:40

Re: meshing
 
What error message are you getting in the adaption process? If you are getting negative elements then that points to the initial mesh not being fine enough on a highly curved surface and the new points created on the true surface of the geometry may force the mesh to overlap on itself.

Are the surfaces you are using poorly parameterized, ideally the display lines should be equally spaced on the surfaces, if not, I suggest you change to the advancing front surface mesher (on the toolbar select Preferences->Mesh mode)


All times are GMT -4. The time now is 03:42.