CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   IGES surface doesn't work (

pete July 15, 2003 04:47

IGES surface doesn't work
Hi everyone,

I want to import a IGES complex curved surface to CFX and I have created the IGES surface in CADKEY V20.

When I import the IGES file, a warning message appears:

Build error for NURBS surface #1

and no surface is created.......

I have no problem importing this IGES file (about 50MB) to the other CAD software like Mechanical desktop...... Thus, this must not be the problem of the file itself. Is that a limitation of CFX5.5.1?

There's no option that I can choose other than IGES format at the moment. Seems like we have to pay extra for the other options. Anyone has the similar problem before?

Thanks for any advice here.

Min July 15, 2003 09:16

Re: IGES surface doesn't work
Please check the unite option.

pete July 15, 2003 11:50

Re: IGES surface doesn't work
can you please say a bit more? What unite option you are referring to?

Thanks for advice anyway.

Min July 15, 2003 13:18

Re: IGES surface doesn't work
Hi, Pete,

1) go to file - new, selecting the unite (mm, ft or so on) same IGES file's unite.

2) import the IGES file.

Pete, you can try this.


Glenn Horrocks July 15, 2003 18:42

Re: IGES surface doesn't work
Hi Pete,

Importing geometry using IGES is always hit and miss. It is common to get surfaces disappearing, surfaces loosing their trimming or just simply going crazy (eg going all wobbly). This is not a problem with CFX-Build, it is just a fact of life with IGES! There is no such thing as a "correct" IGES file, so just because it imported OK into another program does not mean the IGES file is "OK". The IGES code is written and interpreted differently by all the different solid modelling packages.

Even though the CAD import options cost money they are far more reliable and accurate. If you can afford them they are the only way to go.


pete July 15, 2003 23:30

Re: IGES surface doesn't work
Thanks Glenn....Seems like CAD import option is the only way to solve my problem....

All times are GMT -4. The time now is 20:07.