CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   CFX build 5.6 (

Richard September 9, 2003 14:42

CFX build 5.6
Hello All Experts

I seem to have a problem trying to use the mouse functions such as zoom, translate, drag etc, when using CFX build on the LINUX O/S.

I have looked through the manual and can't find any help regarding configuration in cfxbuild 5.6. Does anyone out there know what I need to do to get all the mouse features to work as normal. Everything works fine when I use CFX_post???

Can anyone help me....???


jonathan September 9, 2003 16:17

Re: CFX build 5.6

I have the same problem. I don't think rotate is supported in Build for LINUX. To translate or zoom, use the middle mouse button with the Shift or Ctrl key respectively. Does that help?

Not having the rotate feature is somewhat inconvienient, but can be over come with a bit of persistance.


Richard September 9, 2003 16:21

Re: CFX build 5.6
Hello Johnathan

Thanks for getting back to me so quickly!

I will try your suggestion. Thanks


Robin September 9, 2003 18:52

Re: CFX build 5.6
This does work with Linux. Make sure your middle mouse button function is not being overridden by your window manager.


matej forman September 10, 2003 01:54

Re: CFX build 5.6

Everythink works fine under Linux. Make sure, your NumLock key is off!!!

ps:it does not work for me under Windows (2000). Also the rendering of the black screen is not working properly. Is there any interaction with the Xserver? Has anyone any idea where could be the problem?


Richard September 10, 2003 03:32

Re: CFX build 5.6
Hi Matej

I have it set up on windows 2000 and everything works fine.

I have managed to get it working on Linux also (mandrake 9.0) and all appears to be ok now. What version of X are you using on Linux, I am not sure if this makes a difference but I am using version 4.x.x,?

matej forman September 10, 2003 04:24

Re: CFX build 5.6

I have mandrake 9.1 and its default X version: 4.3 patch level 5mdk to be precise.

I guess, while it is XFree86 4.x.x.. the 'x's do not matter that much.

I'm giving up on Windows.


jonathan September 10, 2003 10:23

Re: CFX build 5.6
Turning Num Lock off solved my problems. Thanks. That had been bugging me for a long time.


Astrid September 10, 2003 12:20

Re: CFX build 5.6
Search for the file /etc/X11/XF86Config

Make a copy first! Then search for

Section "InputDevice"
Identifier "Mouse0"

Make the section look like below:

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"

Especially the "IMPS/2" did the trick for me. If it does not help, you can set the last option to "yes"
which will emulate the middle mouse button by pressing the left and right button. This is espcially
convenient if you do not have a middle mouse button at all.


All times are GMT -4. The time now is 08:59.