CFD Online Logo CFD Online URL
Home > Forums > CFX

Problem with Post calculations

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   August 18, 2004, 17:16
Default Problem with Post calculations
Posts: n/a
I have a problem with calculating and/or understanding some essential parameters from the results file in CFX 5.7 Post. The geometry is very simple: a curved pipe of constant diameter with viscous fluid flow.

I have driven the RMS residuals below 1E-6, so the results must be very accurate. At the end of the solver report the "Pressure Moment on Walls" and the "Viscous Moment on Walls" values are displayed. The total torque on the walls around the Z axis are made of the viscous and pressure components.

I wanted to calculate these two components with the calculator using integrals and compare the results with those displayed by the solver report. When calculated the viscous moment by integrating the (Wall shear*area*radius) then I have got the same result as indicated by the solver report.

However, when integrated the pressure forces, I have got something very different from the value in the solver report. Here is the way I have calculated:

User functions:

fi=atan(Normal Y/Normal X)

Ptan=Pressure*Normal Y*cos(fi)-Normal X*sin(fi)


In the calculator:








While the solver report indicates a pressure moment of about 71 Nm on walls, when integrating the pressure over the tangential surface projection weighted with the radius using the above formulas the result is about 6 E-6 Nm. This is a huge difference, and something must be wrong. When calculating the total torque over the wall surface the result is in consonance with the moment components from the solver report, but not in agreement with the 'manually' calculated components.

If anybody has experience with this issue and knows the answer, please enlighten me where is the error and how should I perform the integration to get the correct result (if the described formulas are wrong). Thank you in advance.


  Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
CAD -> gMsh -> enGrid -> OpenFOAM Problem AlGates OpenFOAM 7 August 6, 2010 12:46
Surface of revolution problem in CFX Post Mankim CFX 3 January 5, 2010 06:38
CFX Post export problem jeff_F CFX 0 August 17, 2009 21:25
Firefox problem: Weird display and inability to post gschaider Site Help, Feedback & Discussions 3 July 22, 2009 04:21
Periodic flow boundary condition problem sudha FLUENT 3 April 28, 2004 08:40

All times are GMT -4. The time now is 12:28.