CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   ICEM problems (http://www.cfd-online.com/Forums/cfx/21242-icem-problems.html)

John May 11, 2005 08:07

ICEM problems
 
Hi everybody,

I'm using ICEM 5.1 to mesh between 2 concentric cylinder (inner and outer cylinder). The clearance between them is really small compared with their radius (more than 100 times smaller). So the surfaces and the curves are not displayed correctly when I zoom on the clearance between the 2 cylinder: the curves are not matching with the surfaces. After repairing the mesh, it's alright but the new curves created are not matching with the original ones. It means that the mesh generated is not correctly attached to the original surfaces. Can someone help me with this problem?

Regards, John

deLuther May 11, 2005 08:32

Re: ICEM problems
 
Do you import geometry or make it in ICEM? And in case of imported geometry from what package? Then you need plaing with tolerance... But if such geometry give acceptable mesh you can neglect this... Sometimes ICEM has such problems. In such cases just delete old(duplicate or incorrect) curves. But can be some situation where even repair will not work.

John May 11, 2005 08:56

Re: ICEM problems
 
I import the geometry from ANSYS in parasolid format (.x_t). Do you think it's a question of tolerance? Thanks

James Date May 11, 2005 11:31

Re: ICEM problems
 
Yep, try drawing the geometry in ICEM rather than importing it. Also make sure you have the best surface rendering option switched on as surfaces can often look like they are not matching curves when in fact they are! Parasolid import usually works, but you might have a tolerance issue on export. It might be worth deleting they imported curves and keeping the surfaces, then doing a geometry repair, this should produce new curves from the surfaces.

James

w0er May 12, 2005 11:18

Re: ICEM problems
 
I Thinl you should delete the old curves,and the creat then in ICEM

John May 12, 2005 11:43

Re: ICEM problems
 
Hi, I tried, but the curves will be attached to the surfaces. And the different faces are not even matching together. That's why I have a problem when I repair the geometry. Or the length of the curves and the area of the surfaces will be modified compared with the original ones. So I don't know how to do... John

Aneshe May 13, 2005 04:18

Re: ICEM problems
 
hi, John 1) delete all curves 2) specify the inner and outter surfaces into different family 3) repair the geometry,then you can got what you expected.

Aneshe

John May 13, 2005 08:23

Re: ICEM problems
 
I'm sorry but it's not working since the inner/outter surfaces are not even matching with the 2 surfaces at the bottom and the top of the ring. So repairing the geometry is not a solution in this case...

deLuther May 14, 2005 04:35

Re: ICEM problems
 
Try to reimport your geometry with lower tolerance (if it is possible to specify tolerance).

ps. From my experience trying to model geometry from begining in ICEM is waste of time... Just my opinion...

Myron June 13, 2005 10:24

Re: ICEM problems
 
The real problem here is the "faceting" of the geometry when read/loaded into ICEM CFD. Although it is B-Spline geometry, it is faceted when loaded into memory. (A perfect geometry would need an infinite amount of memory.) The faceting is controlled by a value called Tri (or Triangle) Tolerance. This especially comes into play when you have a large range of length scales (as you do with 100:1). Read your original Parasolid Geometry. Go into the Global Mesh Settings and look for Triangle Tolerance. It's probably 0.001. Drop this to 0.00001 or 0.000001. Save the geometry and load it back in. You should see better agreement. (This is a value in the tetin file in the last line or so - you can change it in the ASCII file before reading into ICEM.)


All times are GMT -4. The time now is 19:34.