CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

ICEM problems

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 11, 2005, 07:07
Default ICEM problems
  #1
John
Guest
 
Posts: n/a
Hi everybody,

I'm using ICEM 5.1 to mesh between 2 concentric cylinder (inner and outer cylinder). The clearance between them is really small compared with their radius (more than 100 times smaller). So the surfaces and the curves are not displayed correctly when I zoom on the clearance between the 2 cylinder: the curves are not matching with the surfaces. After repairing the mesh, it's alright but the new curves created are not matching with the original ones. It means that the mesh generated is not correctly attached to the original surfaces. Can someone help me with this problem?

Regards, John
  Reply With Quote

Old   May 11, 2005, 07:32
Default Re: ICEM problems
  #2
deLuther
Guest
 
Posts: n/a
Do you import geometry or make it in ICEM? And in case of imported geometry from what package? Then you need plaing with tolerance... But if such geometry give acceptable mesh you can neglect this... Sometimes ICEM has such problems. In such cases just delete old(duplicate or incorrect) curves. But can be some situation where even repair will not work.
  Reply With Quote

Old   May 11, 2005, 07:56
Default Re: ICEM problems
  #3
John
Guest
 
Posts: n/a
I import the geometry from ANSYS in parasolid format (.x_t). Do you think it's a question of tolerance? Thanks
  Reply With Quote

Old   May 11, 2005, 10:31
Default Re: ICEM problems
  #4
James Date
Guest
 
Posts: n/a
Yep, try drawing the geometry in ICEM rather than importing it. Also make sure you have the best surface rendering option switched on as surfaces can often look like they are not matching curves when in fact they are! Parasolid import usually works, but you might have a tolerance issue on export. It might be worth deleting they imported curves and keeping the surfaces, then doing a geometry repair, this should produce new curves from the surfaces.

James
  Reply With Quote

Old   May 12, 2005, 10:18
Default Re: ICEM problems
  #5
w0er
Guest
 
Posts: n/a
I Thinl you should delete the old curves,and the creat then in ICEM
  Reply With Quote

Old   May 12, 2005, 10:43
Default Re: ICEM problems
  #6
John
Guest
 
Posts: n/a
Hi, I tried, but the curves will be attached to the surfaces. And the different faces are not even matching together. That's why I have a problem when I repair the geometry. Or the length of the curves and the area of the surfaces will be modified compared with the original ones. So I don't know how to do... John
  Reply With Quote

Old   May 13, 2005, 03:18
Default Re: ICEM problems
  #7
Aneshe
Guest
 
Posts: n/a
hi, John 1) delete all curves 2) specify the inner and outter surfaces into different family 3) repair the geometry,then you can got what you expected.

Aneshe
  Reply With Quote

Old   May 13, 2005, 07:23
Default Re: ICEM problems
  #8
John
Guest
 
Posts: n/a
I'm sorry but it's not working since the inner/outter surfaces are not even matching with the 2 surfaces at the bottom and the top of the ring. So repairing the geometry is not a solution in this case...
  Reply With Quote

Old   May 14, 2005, 03:35
Default Re: ICEM problems
  #9
deLuther
Guest
 
Posts: n/a
Try to reimport your geometry with lower tolerance (if it is possible to specify tolerance).

ps. From my experience trying to model geometry from begining in ICEM is waste of time... Just my opinion...
  Reply With Quote

Old   June 13, 2005, 09:24
Default Re: ICEM problems
  #10
Myron
Guest
 
Posts: n/a
The real problem here is the "faceting" of the geometry when read/loaded into ICEM CFD. Although it is B-Spline geometry, it is faceted when loaded into memory. (A perfect geometry would need an infinite amount of memory.) The faceting is controlled by a value called Tri (or Triangle) Tolerance. This especially comes into play when you have a large range of length scales (as you do with 100:1). Read your original Parasolid Geometry. Go into the Global Mesh Settings and look for Triangle Tolerance. It's probably 0.001. Drop this to 0.00001 or 0.000001. Save the geometry and load it back in. You should see better agreement. (This is a value in the tetin file in the last line or so - you can change it in the ASCII file before reading into ICEM.)
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Import Mesh from ICEM CFD to CFX Andre Almeida CFX 10 April 20, 2014 15:33
geometry import problems (STEP into ICEM) Toralf CFX 10 March 7, 2014 22:17
[ICEM] Export unstructured periodic mesh from ICEM CFD to Fluent ivanddd ANSYS Meshing & Geometry 1 February 3, 2011 01:51
Design Modeler to ICEM..... Joe CFX 0 January 24, 2008 04:39
re: ICEM vs. ICEM WB Wooster CFX 4 October 15, 2007 12:47


All times are GMT -4. The time now is 02:39.