CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   How to exclude volumes from meshing in ICEM (http://www.cfd-online.com/Forums/cfx/21794-how-exclude-volumes-meshing-icem.html)

Evgeniy November 3, 2005 13:14

How to exclude volumes from meshing in ICEM
 
Hello

I have a newbie ICEM question - I'm trying to mesh a geometry which is not from CAD, but exported from Gambit to ACIS and then imported to ICEM. The geometry contains volumes which should not be meshed. I'm trying to find out how do I exclude these from meshing. Tried to form a body from these but ICEM fails to create a solid body although the chosen surfaces are definetly enclosing a volume. Are there any other ways?

Thank you

Evgeniy


test November 4, 2005 01:13

Re: How to exclude volumes from meshing in ICEM
 
Hi,

All you need to do is to create a body point with the name "orfn" (inverted commas not included!). ICEM will understand that the volume is not to be meshed.

Regards, test

Myron November 4, 2005 13:09

Re: How to exclude volumes from meshing in ICEM
 
To create bodies - you need to run the Build Diagnostic Topology function first - under Geometry > Repair. This gives ICEM the information about connectivity.

It's easier to build Material Points - the other option in the body creation panel. It's easiest with the centroid of 2 points option. Select two locations such that the centroid is in the volume of interest.

Put material points only in the volumes of interest and the other closed volumes will not be preserved in the final mesh. (Or as the other poster said, you could put material points in the ORFN part as well - and those volumes won't be meshed.)


All times are GMT -4. The time now is 15:00.