CFD Online Logo CFD Online URL
Home > Forums > CFX

Negative volume problem in Two-way FSI coupling

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   August 5, 2006, 09:05
Default Negative volume problem in Two-way FSI coupling
Posts: n/a
Hi I am using Ansys 10 and CFX 10 for the two way FSI coupling with MFX license.I have been trying to simulate large deformation problems (in elastic range), but every time when i run, after few timesteps solver exits with a negative volume error.How to overcome this? but this interface works well with small deformation problems.

Some people say restart your analysis form the deformed structure (i.e with a new mesh),if it so does anybody have experienced this type of problem?. I am bit confused how exactly i have to proceed. Any thought on this would be appreciated.

Thanks in advance Fred
  Reply With Quote

Old   August 7, 2006, 12:17
Default Re: Negative volume problem in Two-way FSI couplin
Posts: n/a
Hi Fred,

Have you tried setting the mesh stiffness in CFX? Usually a value of 1 [m^3 s^-1]/Wall Distance or 1 [m^5 s^-1] will solve the problem (see the help doc for more info). You could also try reducing your timestep so that the mesh deformation isn't so drastic.

If you have done both of these things, then maybe your initial mesh quality needs to be improved as suggested. Often meshing a geometry somewhere in between where you expect the geometry to begin and end is a good starting point.
  Reply With Quote

Old   August 8, 2006, 03:27
Default Re: Negative volume problem in Two-way FSI couplin
Posts: n/a
Thanks johnny for your information.

I used the mesh stiffness of 1/wall distance and i tried with the different range of timesteps,but still the cfx solver fails after 15 seconds as the deflection is more in this timestep.

Can anyone could detail the procedure of using the last timestep file as the initial file for the next timestep for FSI Analysis (in both Ansys and CFX)?.

  Reply With Quote

Old   August 16, 2006, 10:03
Default Re: Negative volume problem in Two-way FSI couplin
Posts: n/a
Hi there,

Unfortunately, I am not going to be much help because I am also running 2-way coupled FSI sims between CFX and ANSYS 10 and achieving the same errors. I have used both a mesh stiffness of 1/walldist. and 1/ctrl. vol. and numerous times my simulation has failed due to negative elements being generated (currently my errors are not solved). The reason for my reply is that I am looking at psudoelastic large deformation problems, and I am receiving the same error messages. Is there a chance that there is a bug in the coupling code? Let me know if you have had any breakthroughs.

Some of the tips ANSYS tech support gave me are:

* check units. make sure the units of the geometries in ANSYS and CFX match. Also make sure that the solution units in CFX match the units used to define the ANSYS model.

* double check the material properties, make sure the solid properties of ANSYS are reasonable etc. The solid and fluid domains of the simulation should be able to run ok when looked run in a decoupled analysis
  Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
channelFoam for a 3D pipe AlmostSurelyRob OpenFOAM 3 June 24, 2011 13:06
error in two way fsi kmgraju CFX 1 May 2, 2011 02:32
blockMesh error ... balkrishna OpenFOAM Pre-Processing 0 August 17, 2010 02:39
Negative Volume Problem Alicia CD-adapco 1 July 27, 2005 07:05
Problem in identifying Negative volumes in Fluent Senthil FLUENT 1 April 19, 2003 10:16

All times are GMT -4. The time now is 18:15.