CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   error message (http://www.cfd-online.com/Forums/cfx/23000-error-message.html)

anna August 29, 2006 04:06

error message
 
Dear all,

I am making my model for the n-time and I do not know the reason for the following error message. Enclosed, please find the message attached as well a picture of the model. I use the symmetry over XY-plane and I checked it many times that all the nodes from my mesh are at Z=0. Can you give me some ideas? Thanks a lot!

P.S. Actually, is it possible to attache something and how?

anna August 29, 2006 04:20

Re: error message 2
 
the error message follows:

ERROR #002100025 has occurred in subroutine Chk_Splane. | | Message: | | The symmetry boundary condition requires that the boundary patch | | mesh faces form a plane or axis. However, face set 5 in the | | symmetry boundary patch | | | | symm former | | | | is not in a strict axis, which means that at least one of its | | faces is not parallel to the others. To make the solver run | | you can do one of the following: | | | | (1) Make sure that this symmetry boundary patch is in a plane or | | axis by checking and regenerating the mesh. | | (2) If the symmetry boundary patch is plane rather than an axis, | | change the tolerance of the degeneracy check by decreasing | | the value of the Solver Expert Parameter | | 'degeneracy check tolerance' (the default value is 1.e-4). | | (3) Increase the value of the Solver Expert Parameter | | 'vector parallel tolerance' (the default value is 1 deg.). | | Note that the accuracy of the symmetry condition may decrease | | as the tolerance is increased. This is because the tolerance | | is the number of degrees that a mesh face normal is allowed | | to deviate from the average normal for the entire face set.

lu August 29, 2006 04:27

Re: error message 2
 
This problem can be solved if you change the expert parameters as CFX suggests. I had the same message with a tetra mesh because surfaces are not perfectly planar. In this situation, you can try to make first a surface mesh and then a volume one. Usually, in this way, I obtain a smoother mesh and CFX recognises simmetry.

anna August 29, 2006 04:36

Re: error message 2
 
Hi Lu,

yes, I have done first 2D mesh and then I generated cylindlical volumes from the areas and the corresponding elements. My mesh is hex. I'll try this tip and let's see.Thanks a lot.

anna August 29, 2006 04:44

Re: error message 3
 
hi,

how much do I have to change these parameters, now they look like this:

EXPERT PARAMETERS:

degeneracy check tolerance = 1.e-5

vector parallel tolerance = 6.0

and even so I received this error again.

some tips, please!

alex August 29, 2006 04:51

Re: error message 3
 
anna, have you smoothed your mesh coorectly in icem cfd? what kind of criteria? do you specify frozen mesh surface during the smoothing time?

alex


anna August 29, 2006 04:56

Re: error message 4
 
O.K. now by the last attempt:

The CFX hints are: to decrease the degeneracy check tolerance for one part of the model and to increase the same parameter for another part of the model. Such a contradiction!!!

anna August 29, 2006 04:58

Re:
 
Hi Alex,

I am doing the mesh in ANSYS, then making components out of the elements - for different solid structure, and components out of nodes - for the boundary conditions and loads. This is actually a requirements in order to import the mesh in CFX.

Anna

lu August 29, 2006 07:40

Re: error message 4
 
Dear Anna, when I contact for the same problem our technical support, they told me to set the expert parameters to very high value, for example:

degeneracy check tolerance = 1

vector parallel tolerance = 50

You can also increase the values until CFX allowes it because you are sure that the flow is simmetryc.

However, I had these problems only with tetra meshes, because usually hexa meshes have really planar surfaces.


Robin August 29, 2006 12:34

Re: error message
 
Hi Anna,

If the mesh is coming from ICEM CFD, check that there isn't a non-planar element face that has been projected to your symmetry plane. This is often the cause of these errors.

A good way to find it is to bring the mesh into Post and create a point the highest Z (or X, or Y) location to identify where the face is out of plane.

-Robin

anna August 29, 2006 15:58

one possible solution
 
Dear everyone,

if ever such a problem occurs to you there is also another possibility, which unfortunately does not work in my case, you have to separate in different components of node all the areas included in one symmetry.

Good night Anna


All times are GMT -4. The time now is 10:04.