CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Distribuited Parallel (

massimo October 10, 2006 03:16

Distribuited Parallel
Hi, I have a problem with the PVM distribuited parallel. The machine configuration is:

1. 2xOpteron 260 8Gb Ram 2. 2xOpteron 260 8Gb Ram 3. 2xOpteron 260 8Gb Ram

(all the machine have WinXp64 and identical software configuration)

when I start the simulation I receive the message:

PVM-error flag from notifying missing partition: -31

Anyone can help me for this problem?

Thank's in advance


Bian October 10, 2006 09:40

Re: Distribuited Parallel
Are you using CFX11 P5? If so, the distributed parallel is not working for XP64. Download P6 or later version, but the distributed parallel scalability is not good.

I would be very interested in the speed of your machines. Could you run the benchmark file coming with CFX and report the parallel speed here? Thanks.


massimo October 10, 2006 10:46

Re: Distribuited Parallel
Hi, no I'm using CFX 10. I run the benchmarck as soon as possible... Thank's Bye m.

HekLeR October 10, 2006 22:08

Re: Distribuited Parallel
Windows parallel scales perfectly fine for me. You must be doing something wrong setup wise or how you are measuring it.

massimo October 11, 2006 06:24

Re: Distribuited Parallel
Is working fine the PVM with XP64?

Bian October 11, 2006 08:38

Re: Distribuited Parallel
CFX10 SP1 for XP4 distributed parallel should work. But I got very poor speed gain even for local PVM parallel. Can you get good scale for local PVM? MPICH would be much better. My machine is woodcrest CPU, so very interested in your AMD CPU speed.

HekLeR October 11, 2006 22:12

Re: Distribuited Parallel
32 bit cfx10 works

64 bit cfx11 beta versions do not yet. you might ask support for an update.

All times are GMT -4. The time now is 03:31.