CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Reduce size of Ansys.rst file in FSI simulations? (

Jorn May 23, 2007 16:34

Reduce size of Ansys.rst file in FSI simulations?
Hello, In performing transient FSI simulations with Ansys/CFX, the ansys.rst file that is created is huge (several Gb!!).

Is there a way to reduce the size of this file?

Thanks, Jorn

steve May 23, 2007 17:43

Re: Reduce size of Ansys.rst file in FSI simulatio
I got the same problem in a static aeroelasticity simulation. The only way is not to spend extra 'coupling time iterations' for convergence. For example in a static case if the problem converges in 4 coupling steps (using a convergence criterion,e.g.mesh displacement), you should avoid using any more, because ansys rst file contains everything! In your transient case, which you are not seeking for equilibrium state, try the options in writting output files and reduce some number of output time steps (if you have too many), this should propably reduce gbs.

Omer May 24, 2007 03:16

Re: Reduce size of Ansys.rst file in FSI simulatio
Use the OUTRES command in ANSYS to write only the results that you desire for each loadstep. The help in ANSYS on OUTRES is good. The saving in space can be huge!

Now, how much will this affect your coupled analysis is what I am not sure off.

Jorn May 24, 2007 16:01

Re: Reduce size of Ansys.rst file in FSI simulatio
Thanks for the responses. I decreased the number of results written each step in both ANSYS and CFX. Also made the meshes smaller. Results are still few hundred MB but at least not >10 GB!!

kiben17 October 31, 2010 19:45

ANSYS mechanical transient thermal, OUTRES command help
Hi everyone,

I'm trying to reduce the size of my output file from ANSYS mechanical transient thermal by using the outres command outres,all,-100, to create save points at 100 equally spaced times. However, I can't get it to work, it will automatically save every time it has calculated. I've tried doing


to eliminate any defaults, but that hasnt worked. Ive also turned off 'calcaulate thermal flux' but that also hasnt worked.

I'd be gratfeul if anyone has any ideas!


adeban November 2, 2010 06:26


Outres doesnt work in the MFX solver environment. You should use the mfoutput command instead. Check the help for mfoutput command. Similarly, if you want to write restart files you need to use mfrc instead of the traditional ansys command.

Klas Johansson, Ph.D.
Technical Consultant

EDR | Engineering Data Resources AB |
+46 31 759 5035 (tel) | +46 (0)708 87 92 72 (mobile)

EDR blog

All times are GMT -4. The time now is 17:01.