CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

HP MPI warning...Distributed parallel processing

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 5, 2008, 14:21
Default HP MPI warning...Distributed parallel processing
  #1
Peter
Guest
 
Posts: n/a
Hi I want to use HP MPI scheme for distributed parallel processing. I use following command script.

root/cfx5solve -def *.def -ini *.res -double -par-dist $NODES -start-method "HP MPI Distributed Parallel" -size-part 4.0

But it gives me following warning. Could any body suggest some solution.

Thanks.

***************************Warning**************** ******** Warning ! The current start method, HP MPI Distributed Parallel, is not a standard PVM parallel start method, and so the parallel option cannot be changed independently to Distributed Parallel. Request ignored.

If you are using both -start-method and -par-local or -par-dist on the command line, you can move the -start-method switch to after the -par-* switch.

  Reply With Quote

Old   February 5, 2008, 14:39
Default Re: HP MPI warning...Distributed parallel processi
  #2
UnderwaterAlex
Guest
 
Posts: n/a
Hi Peter,

I get that warning too, but I generally ignore it. My cases always run on the correct nodes using the solver-hpmpi executable so I figured it was fine. Are your cases not running appropriately?

-Alex
  Reply With Quote

Old   February 5, 2008, 14:52
Default Re: HP MPI warning...Distributed parallel processi
  #3
Peter
Guest
 
Posts: n/a
Hi Alex,

Though the command '-start-method "HP MPI Distributed Parallel"' gives warning but the correct number of nodes are allocated to my simulation. Simulation goes well. I also have been ignoring this warning but wanted to discuss view of other people.

By the way, is solver-hpmpi a different executable? What does it mean?

-Peter
  Reply With Quote

Old   February 5, 2008, 18:09
Default Re: HP MPI warning...Distributed parallel processi
  #4
UnderwaterAlex
Guest
 
Posts: n/a
When you run CFX it chooses a different executable depending on whether it is a serial or parallel run, and which mpi libraries are utilized. I might not be stating this exactly correctly (I am no software engineer), but basically the executable depends on which libraries were included in compiling the code and are therefore necessary to run the code in this configuration. A serial run uses solver-pvm.exe, hp mpi runs use solver-hpmpi.exe, etc. Even if you get this message, it doesn't seem to matter since the correct nodes are running the hp mpi executable. That's pretty much everything I know about it. I go with the "If it ain't broke, don't fix it" philosophy on this one.
  Reply With Quote

Old   February 5, 2008, 18:19
Default Re: HP MPI warning...Distributed parallel processi
  #5
Peter
Guest
 
Posts: n/a
Thank you very much Alex. I also agree with your philosophy. Your reply is full of useful information and I will try to understand it with the help of my friends who are rich in computer's knowledge.

  Reply With Quote

Old   January 3, 2010, 14:57
Default
  #6
Member
 
h-h
Join Date: Sep 2009
Posts: 38
Rep Power: 7
hosseinhgf is on a distinguished road
hi
excuse me for my english.
I have a problem to use "hp mpi" in windows xp x64.
I use ansys help to install the servise but it dosent work.
in cfx>tools>command type "cfx5parallel -install-hpmpi-service" and it installed then type "cfx5parallel -register-hpmpi-user" then it want password, after enter password this error is showing "mpid: cannot conect to mpirun".
can i use hp mpi in local machin whit multi processor?
i can install and use mpich2 but system restart is always occur.
hosseinhgf is offline   Reply With Quote

Old   February 8, 2010, 10:56
Default
  #7
New Member
 
Join Date: Mar 2009
Location: Seoul, Korea
Posts: 6
Rep Power: 8
peaksun is on a distinguished road
Quote:
Originally Posted by hosseinhgf View Post
hi
excuse me for my english.
I have a problem to use "hp mpi" in windows xp x64.
I use ansys help to install the servise but it dosent work.
in cfx>tools>command type "cfx5parallel -install-hpmpi-service" and it installed then type "cfx5parallel -register-hpmpi-user" then it want password, after enter password this error is showing "mpid: cannot conect to mpirun".
can i use hp mpi in local machin whit multi processor?
i can install and use mpich2 but system restart is always occur.
I encounterd the same problem. My OS is windows server 2003 and CFX version is 12. Does anyone konw how to run CFX in 'HPMPI Local Parallel' mode under windows 64bit os?
peaksun is offline   Reply With Quote

Old   February 8, 2010, 18:07
Default
  #8
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 10,814
Rep Power: 85
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
HP-MPI works fine for me. I just followed the instructions in the documentation. If you have read the trouble shooting section in the manual and it does not help then will have to contact CFX support.
ghorrocks is offline   Reply With Quote

Old   February 8, 2010, 19:17
Default
  #9
Member
 
h-h
Join Date: Sep 2009
Posts: 38
Rep Power: 7
hosseinhgf is on a distinguished road
finally i install hp mpi.i just make a virtual network and using ansys help.
my computer restart was from my mainboard(ma790x-ds4). the "isl" of mainboard power was failed. i repaired it three time but finally i had to buy a new one(ma790gp-ud4h).
hosseinhgf is offline   Reply With Quote

Old   May 13, 2011, 10:02
Default hp mpi not installing on wind 7 64 bit Ansys CFX
  #10
New Member
 
david malins
Join Date: May 2011
Posts: 1
Rep Power: 0
dave malins is on a distinguished road
Dear all,
I've installed CFX 13 but I try and install the hpmpi service and it gives the following error, without getting into the install. It can't get the registry so I'm assuming it's something up with my OS. Has anyone got any ideas?

much appreciate the help
dave
Attached Images
File Type: jpg hpmpi error installing.jpg (44.6 KB, 46 views)
dave malins is offline   Reply With Quote

Old   May 14, 2011, 06:17
Default
  #11
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 10,814
Rep Power: 85
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
Are you sure you are installing as admin? If you cannot write to the registry you will get error messages like that.
ghorrocks is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
latest OpenFOAM-1.6.x from git failed to compile phsieh2005 OpenFOAM Bugs 25 February 9, 2010 05:37
Version 15 on Mac OS X gschaider OpenFOAM Installation 120 December 2, 2009 11:23
Compilation errors in ThirdPartymallochoard feng_w OpenFOAM Installation 1 January 25, 2009 07:59
Axisymmetrical mesh Rasmus Gjesing (Gjesing) OpenFOAM Native Meshers: blockMesh 10 April 2, 2007 14:00
Warning 097- AB CD-adapco 6 November 15, 2004 05:41


All times are GMT -4. The time now is 22:10.