CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

ANSYS Workbench on "Uncertified" Linux Distros

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree6Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   January 14, 2011, 11:43
Default
  #101
New Member
 
fabio moretti
Join Date: Jan 2011
Location: Pisa
Posts: 4
Rep Power: 5
fabio moretti is on a distinguished road
Hi everybody

This is my first appearance on this forum, I apologize in advance should I be missing something important. And thank you for sharing your ideas, problems and solutions.

Scott Johnson:
It seems I have the same troubles as you have, I mean the CCL errors.
I installed ANSYS CFX 13.0 on a Fedora 13 x86_64 desktop, with an nvidia display adapter (the driver being the one provided by fedora).
After some iterations (requiring some yum installs) I got to a complete install without error messages. The problem arises when trying to define a new case with CFX-Pre, as well as when simply closing CFX-Pre GUI.
By the way, I also installed the code on a Fedora 8 server, where it runs fine; on the other hand I would like to abandon such distro because it gives me troubles with other software packages.
Have you got any good news? Thanks.

Regards to you all
fabio
fabio moretti is offline   Reply With Quote

Old   January 14, 2011, 18:10
Default
  #102
New Member
 
Charlotte
Join Date: Oct 2009
Posts: 16
Rep Power: 7
charlotte is on a distinguished road
As I posted before, I didn't get any luck with Ubuntu/CAELinux (CCL errors). Too bad, I wanted to play with CAELinux a little bit, but I guess it will be for another time.

I made a clean install with OpenSuse 11.2 64bit and install Workbench/CFX without trouble (installing my graphic card was much more painful...). Everything is working: DM, Mesh, CFXPre, CFXsolver & CFXPost.
charlotte is offline   Reply With Quote

Old   January 17, 2011, 08:36
Default
  #103
New Member
 
Join Date: Jan 2011
Posts: 10
Rep Power: 5
ginggs is on a distinguished road
Quote:
Originally Posted by makkemal View Post
Ubuntu 10.04
With the steps above 12.1 runs fine
in 13 I get the following errors on the same machine

QPainter::setFont: Painter not active
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread

Anyone seen this

Thanks
M
I had exactly the same problem; 12.1 runs fine but 13.0 not starting. Thanks to this thread I removed ~/.ansys and ~/.config/Ansys and the problem was solved.
ginggs is offline   Reply With Quote

Old   January 17, 2011, 10:16
Default
  #104
ffg
New Member
 
surfer
Join Date: Jan 2011
Posts: 4
Rep Power: 5
ffg is on a distinguished road
I have ubuntu 10.10 64 bit and I followed all the instructions given by yankee to install Ansys 12.1 . Only one difference: I used the noroot flag to install the software. Ansys workbench starts, the Design Modeler starts but it doesn'tt work. The interface starts but I can't do anything and if I try to close it it gives a "script error" on a little windows and the "workbench error: error connecting to albion"; in the starting shell. ( The same steps on a ubuntu 9.10 64 bit lead to a successful installation. All works). Any idea? ffg
ffg is offline   Reply With Quote

Old   January 17, 2011, 11:29
Default
  #105
New Member
 
Join Date: Jan 2011
Posts: 10
Rep Power: 5
ginggs is on a distinguished road
Quote:
Originally Posted by ffg View Post
I have ubuntu 10.10 64 bit and I followed all the instructions given by yankee to install Ansys 12.1 . Only one difference: I used the noroot flag to install the software. Ansys workbench starts, the Design Modeler starts but it doesn'tt work. The interface starts but I can't do anything and if I try to close it it gives a "script error" on a little windows and the "workbench error: error connecting to albion"; in the starting shell. ( The same steps on a ubuntu 9.10 64 bit lead to a successful installation. All works). Any idea? ffg
I think this may be the solution for you:
Quote:
Originally Posted by makkemal View Post
ANSYS expects to find libGL.so.1 in /usr/lib/.
The following solved my problem:

For Nvidia drivers

sudo ln -s /usr/lib/nvidia-current/libGL.so.1 /usr/lib/libGL.so.1

For Mesa drivers

sudo ln -s /usr/lib/mesa/libGL.so.1 /usr/lib/libGL.so.1
ginggs is offline   Reply With Quote

Old   January 17, 2011, 11:30
Default
  #106
New Member
 
Yves Delannoy
Join Date: Feb 2010
Location: Grenoble, France
Posts: 23
Rep Power: 6
Yankee is on a distinguished road
Quote:
Originally Posted by ffg View Post
I have ubuntu 10.10 64 bit and I followed all the instructions given by yankee to install Ansys 12.1 . Only one difference: I used the noroot flag to install the software. Ansys workbench starts, the Design Modeler starts but it doesn'tt work. The interface starts but I can't do anything and if I try to close it it gives a "script error" on a little windows and the "workbench error: error connecting to albion"; in the starting shell. ( The same steps on a ubuntu 9.10 64 bit lead to a successful installation. All works). Any idea? ffg
I experienced this "workbench error: error connecting to albion" when my /etc/hosts file had twice the name of my machine on two uncommented lines. I edited it, commented the second one (which was related to ipv6), and all trouble was gone.

The only difficult point is that, at least on laptops changing regularly their network configuration, the networkmanager re-inserts regularly this double declaration in /etc/hosts . A web request indicates that this is a known behavior of network manager, which seems not considered as a bug. To avoid it you can make /etc/hosts immutable (with the chattr command) or modify your workbench script to comment the second one automatically (but I only find a solution with sudo, that asks your password each time).
Yankee is offline   Reply With Quote

Old   January 17, 2011, 11:48
Default
  #107
ffg
New Member
 
surfer
Join Date: Jan 2011
Posts: 4
Rep Power: 5
ffg is on a distinguished road
@ginggs
I have the nvidia driver 260.19.29 and libGL is already linked to that.

@yankee
that was it!!! I thought I had all my hostname removed but one, but I had this line
::1 hostname localhost6.localdomain6,localhost6
that caused the trouble. commented the line and design modeler works !!!

Thank you very much ffg
ffg is offline   Reply With Quote

Old   January 17, 2011, 14:12
Default
  #108
New Member
 
Rafael Oliveira
Join Date: Mar 2010
Posts: 6
Rep Power: 6
rafasdo is on a distinguished road
I would like to express my thanks to everyone for your contributions. I did make the instalation of ansy13 in Ubuntu 10.10 x86_64 following the steps of Yankee and now everything is working: DM, MESH, Fluent. Below is some information that might be useful:


1 I installed the pack: ia32-libs

2 file /etc/hosts: I did make as proposed, but appear the err: "RPCSS ServiceMain failed with 1702 (000006a6)'. To solve the problem I left the file hosts as follows:


127.0.0.1 hostname.domain hostname localhost.localdomain localhost
# The following lines are desirable for IPv6 capable hosts
::1 localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


3 libGL: Before of create a link to libGL library, i used the command to find it:
find /usr -print | grep -i "libGL.so.1"

Last edited by rafasdo; January 18, 2011 at 15:13.
rafasdo is offline   Reply With Quote

Old   January 20, 2011, 15:42
Default
  #109
New Member
 
Scott Johnson
Join Date: Nov 2010
Posts: 14
Rep Power: 6
Scott Johnson is on a distinguished road
Quote:
Originally Posted by charlotte View Post
As I posted before, I didn't get any luck with Ubuntu/CAELinux (CCL errors). Too bad, I wanted to play with CAELinux a little bit, but I guess it will be for another time.

I made a clean install with OpenSuse 11.2 64bit and install Workbench/CFX without trouble (installing my graphic card was much more painful...). Everything is working: DM, Mesh, CFXPre, CFXsolver & CFXPost.
Similar to Charlotte, I also moved to a different distro after failing to fix the CCL errors in Ubuntu on my new machine. I installed CentOS 5.5 and everything is also working.

In configuring all the hardware and installing the software I need on CentOS, I am reminded why I moved to Ubuntu several years ago. I sure wish I could have been able to resolve the CCL errors.
Scott Johnson is offline   Reply With Quote

Old   January 25, 2011, 08:44
Default Ansys WB on fedora 11 x86_64
  #110
New Member
 
Martin Nesladek
Join Date: Jan 2011
Posts: 2
Rep Power: 0
rasov24 is on a distinguished road
Hello!

Is anybody here who was able to run successfully Ansys WB 13.0 on fedora 11 x86_64? For me, installation went smoothly. After that I only found some warning message in install.err which is following:
Code:
>>>--------------------------------------->
ANSYS installation: Mon Jan 24 16:41:22 2011
Revision: 13.0

   Warning!
   Host name lookup failed for host "myhostname"
>>>--------------------------------------->
When I run WB through /ansys_inc/v130/Framework/bin/Linux64/runwb2 everything seems correct till I try to start DM, meshing or some other module. After some time of playing I got these messages in terminal:
Code:
Aborting due to unexpected error:
hostError: Socket::connectHostPort - gethostbyname - HOST_NOT_FOUND: Authoritative Answer Host not found
Warning: token %1 was not used in the message: "socketError: Socket::waitForConnection - Connection timeout after 120s"Warning: token %1 was not used in the message: "socketError: Socket::waitForConnection - Connection timeout after 120s"Aborting due to unexpected error:
comm::error: AppWindow::initialize - Error waiting for viewer connection from engine:

The application has encountered an unexpected problem and will now terminate:

Aborting due to unexpected error:
comm::error: AppWindow::initialize - Error waiting for viewer connection from engine:


Please report this error, along with the circumstances in which it occurred.

The following information may be useful to CFX support:

Unexpected error: Aborting due to unexpected error:
comm::error: AppWindow::initialize - Error waiting for viewer connection from engine:



Warning!

CFD-Post exited with return code 3
I am not sure if the above message is related to lack of license tokens or something else (I am new to this software). But the biggest problem is DM and meshing don't want to start...

Of course I have read previously suggested solutions that work for Ubuntu or Debian. But in fedora some of them cause other problems in the system without helping with WB (for example, if I add /ansys_inc/v130/Framework/bin/Mesa or
/ansys_inc/v130/Framework/bin to LD_LIBRARY_PATH).

Any suggestions? Thanks in advance!

Martin
rasov24 is offline   Reply With Quote

Old   February 2, 2011, 05:22
Default wb13 on both ubuntu 10.10 and fedora 12
  #111
ffg
New Member
 
surfer
Join Date: Jan 2011
Posts: 4
Rep Power: 5
ffg is on a distinguished road
I installed ansys 13 on both ubuntu 10.10 and fedora 12. I followed the tutorial of the elbow. Everything was working until I tried to run CFD-Post (clicking on results)
On both the platform I get this error:

------
Application Error in CFD-Post
ERROR
CCL validation failed with message:
value 'Coordinate Frame' is not allowed for parameter /DEFAULT INSTANCE TRANSFORMefault Transform/Rotation Axis Type

SEVERE
An attempt to recover from a previous error has failed. The application is likely to be in an unstable state
------
and in fact the application does not display any contour, vectors and so on.

Anybody knows hot to get it working?

thanks
ffg
ffg is offline   Reply With Quote

Old   February 2, 2011, 11:53
Default
  #112
New Member
 
Martin Nesladek
Join Date: Jan 2011
Posts: 2
Rep Power: 0
rasov24 is on a distinguished road
Hello, ffg!

I can't figure out what you mean by:

Quote:
I followed the tutorial of the elbow
Can you please post the procedure you have used to get WB working on fedora? Thanks!

Martin
rasov24 is offline   Reply With Quote

Old   February 3, 2011, 04:56
Default
  #113
ffg
New Member
 
surfer
Join Date: Jan 2011
Posts: 4
Rep Power: 5
ffg is on a distinguished road
Quote:
Originally Posted by rasov24 View Post
Hello, ffg!

I can't figure out what you mean by:



Can you please post the procedure you have used to get WB working on fedora? Thanks!

Martin
The elbow I was talking about is the first tutorial "Tutorial 1. Introduction to Using ANSYS FLUENT in ANSYS WORKBENCH: Fluid Flow and Heat Transfer in a Mixing Elbow"
http://www1.ansys.com/customer/conte...ent/flwbtg.pdf

The procedure to get the workbench (but not CFD-post) working in fedora 12 has been the following:
I missed ld-linux.so.2 , libstdc++.so.6, libXext.so.6, lsb
I installed them with the command "yum install librarytobeinstalled"

install ANSYS 13 disabling SElinux (if you have it) and that's it apart for being cautious to the file /etc/hosts as already written in this forum.

run the program disabling SElinux (if you have it)

Last edited by ffg; February 3, 2011 at 04:58. Reason: forgot a small part
ffg is offline   Reply With Quote

Old   February 22, 2011, 08:52
Default
  #114
New Member
 
Vadim
Join Date: Feb 2011
Posts: 12
Rep Power: 5
Conakry is on a distinguished road
Hi all!

I have the ArchlinuxOS x86_64, Ansys 13 and two questions...
1. Why does DM start so looong time? It`s 10 minutes approximately.
2. Why does ME crach after the looong attempt to start?

My regards!
Conakry is offline   Reply With Quote

Old   February 24, 2011, 09:42
Default
  #115
Member
 
Nikolopoulos Aristeidis
Join Date: Jan 2011
Location: Athens, Greece
Posts: 62
Rep Power: 5
Nikolopoulos is on a distinguished road
Hello!

I cannot install ANSYS13.0 in fedora 14 (64bit)

I used yum -y install INSTALL
but it replies that INSTALL is not a package?
Do you know which file should i yum?????
Nikolopoulos is offline   Reply With Quote

Old   February 24, 2011, 10:20
Default
  #116
New Member
 
Vadim
Join Date: Feb 2011
Posts: 12
Rep Power: 5
Conakry is on a distinguished road
Quote:
Originally Posted by Nikolopoulos View Post
Hello!

I cannot install ANSYS13.0 in fedora 14 (64bit)

I used yum -y install INSTALL
but it replies that INSTALL is not a package?
Do you know which file should i yum?????
Sure, INSTALL is not a package...it`s shell-script.
You`d run it independently.
Conakry is offline   Reply With Quote

Old   February 24, 2011, 10:28
Default THanks for the reply!
  #117
Member
 
Nikolopoulos Aristeidis
Join Date: Jan 2011
Location: Athens, Greece
Posts: 62
Rep Power: 5
Nikolopoulos is on a distinguished road
How should i install ANSYS13 in Fedora?

Keep in mind that i'm new to Linux!
Nikolopoulos is offline   Reply With Quote

Old   February 24, 2011, 10:33
Default
  #118
New Member
 
Vadim
Join Date: Feb 2011
Posts: 12
Rep Power: 5
Conakry is on a distinguished road
Quote:
Originally Posted by Nikolopoulos View Post
How should i install ANSYS13 in Fedora?

Keep in mind that i'm new to Linux!
That`s simply.
Run any terminal program, enter to Ansys13-media and perform INSTALL-script:
Code:
$ ./INSTALL
Conakry is offline   Reply With Quote

Old   February 24, 2011, 10:36
Default
  #119
Member
 
Nikolopoulos Aristeidis
Join Date: Jan 2011
Location: Athens, Greece
Posts: 62
Rep Power: 5
Nikolopoulos is on a distinguished road
Thanks I did it but i got the following

[root@aris Desktop]# ./INSTALL
copying necessary files to /tmp/ans_install_tmp4121/
Executing /tmp/ans_install_tmp4121/instcore
/tmp/ans_install_tmp4121/INSTALL: /tmp/ans_install_tmp4121/instcore: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory
Nikolopoulos is offline   Reply With Quote

Old   February 24, 2011, 10:44
Default
  #120
New Member
 
Vadim
Join Date: Feb 2011
Posts: 12
Rep Power: 5
Conakry is on a distinguished road
Quote:
Originally Posted by Nikolopoulos View Post
Thanks I did it but i got the following

[root@aris Desktop]# ./INSTALL
copying necessary files to /tmp/ans_install_tmp4121/
Executing /tmp/ans_install_tmp4121/instcore
/tmp/ans_install_tmp4121/INSTALL: /tmp/ans_install_tmp4121/instcore: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory
Show here your /lib64-folder contents...
Conakry is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
LINUX Experts: Help with installing ANSYS workbench faisal_durr ANSYS 1 May 30, 2014 09:07
Ansys workbench problem Jonny6001 ANSYS 2 September 30, 2010 13:59
How can I start the ANSYS 12 workbench in LINUX Ardisia ANSYS 3 September 7, 2010 01:19
ANSYS Workbench on Linux CPUcruncher ANSYS 4 July 11, 2010 10:19
ANSYS Workbench on "Certified" linux distro mechanicaldesign CFX 0 April 16, 2010 02:56


All times are GMT -4. The time now is 10:26.