CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   Advice on this mesh (http://www.cfd-online.com/Forums/cfx/25559-advice-mesh.html)

Rodrigo Basniak March 30, 2008 09:19

Advice on this mesh
 
Hi,

can I have some advice on this mesh?

I made the model on SolidWorks, it's an airfoil 200mm chord lenght with slots.

I did the following:

-> Imported geometry -> Made the 2D regions -> Set options to 2D extruded mesh, with 1 layer and then the peridic pairs -> Set Deafult Body Spacing to 0.05m -> Set Default Face Spacing to 0.005m and 0.1m (minimum and maximum edge lenghts)

Then I generate the surface meshes and I got this result:

http://img180.imageshack.us/img180/3627/fig1ht2.jpg

Now I added two Face Spacings: -> Airfoil, Constant, 0.0005m`, 1.1 expansion -> Slot, constant, 0.00025m, 1.1 expansion

Generating the surfaces again and the mesh stay exactly the same, but now I got this Warning:

Warning One or more face or edge spacings may not have the desired effect because they have been set on objects that are not associated with the extruded periodic pair.

You might want to try using point, line or triangle controls to achieve the required mesh spacing in the periodic regions.

I tried doing what it sugests and made a point control but the mesh is yet the same... nothing changed and the warning continues...

:(

Any advices?

Thanks in advance, Rodrigo Basniak

Dre March 30, 2008 13:50

Re: Advice on this mesh
 
I would try some edge spacings instead of face spacing. Set the option to constant

Rodrigo Basniak March 30, 2008 13:59

Re: Advice on this mesh
 
Same result, nothing seems to change de mesh :(

Carlos March 30, 2008 14:59

Re: Advice on this mesh
 
Proximity > Surface Proximity "On"

Steven March 31, 2008 07:29

Re: Advice on this mesh
 
If the above doesnt work, try turning off the the periodic pair out of intrest...

Steve

Rodrigo Basniak March 31, 2008 08:46

Re: Advice on this mesh
 
It didn't, I'll try the periodic thing when I get home. Just one question: since it's a 2D mesh it automatically makes me choose a periodic. Do I just suppress it and it's all ok?

Regards, Rodrigo Basniak

Rodrigo Basniak March 31, 2008 22:27

Re: Advice on this mesh
 
It doesnt allow me to suppress the Periodic since it's a 2D mesh...

I think the cause nothing changes is that warning but the documentations doesn'say anything about that message :(


Steven April 1, 2008 15:05

Re: Advice on this mesh
 
Hi

Going back to when I did a 2D study on my airfoil, i think i had more than one element thick, its not strictly 2D but the results should still be the same....then again neither is just having one element thick :)

Sorry I cant be more help

Steven


All times are GMT -4. The time now is 11:26.