CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

Question concerning user_get_gvar

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 16, 2008, 05:57
Default Question concerning user_get_gvar
  #1
Benjamin
Guest
 
Posts: n/a
Dear CFX users,

I want to couple CFX with a post-processing tool called Covise. It should be a online coupling. So I need after every coefficient loop the values of all the variables (Temperatur, Pressure,.....). First I wrote a Junction Box Routine only to get the temperature to test it. Here it is:

#include "cfx5ext.h"

dllexport(user_output)

SUBROUTINE USER_OUTPUT (CZ, DZ, IZ, LZ, RZ)

C --Preprocessor includes--

#include "MMS.h"

#include "cfd_constants.h"

C --Arguments--

CHARACTER CZ(*)*(1)

DOUBLE PRECISION DZ(*)

INTEGER IZ(*)

LOGICAL LZ(*)

REAL RZ(*)

C --Local variables--

CHARACTER*(4) CRESLTC

REAL VAR, rtemperature

C --Executable statements--

CALL USER_GET_GVAR ('Temperature','StaticMixer',

& 'area',CRESLT,rtemperature,CZ,DZ,IZ,LZ,RZ)

CALL MESAGE ( 'WRITE', 'Temperatur: ', rtemperature)

END

I built the user_output.dll with the cfx5mkext -> No problems. But this routine doesn't work. I don't receive the temperature on the console. How can I acces my rtemperature variable? I use win xp pro sp2 x64 and CFX V10.0

Is this the right solution to get data with user_get_gvar to couple cfx with another tool, or should I use stackpointers?

Thanks for all help.

Greetings Benjamin
  Reply With Quote

Old   April 16, 2008, 07:56
Default Re: Question concerning user_get_gvar
  #2
Benjamin
Guest
 
Posts: n/a
I found a mistake. I didn't activate the junction box routine in the solver control panel.... Now I get Temperature on the console after every coefficient loop, but its value is always 0. Why? I use the static mixer example, located in ../examples.

Thanks for help

Greetings Benjamin
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unanswered question niklas OpenFOAM 2 July 31, 2013 16:03
internal field question - PitzDaily Case atareen64 OpenFOAM Running, Solving & CFD 2 January 26, 2011 16:26
Question about Table applicaiton. universez OpenFOAM Running, Solving & CFD 0 January 12, 2010 21:31
CHANNEL FLOW: a question and a request Carlos Main CFD Forum 4 August 23, 2002 05:55
question K.L.Huang CD-adapco 1 March 29, 2000 04:57


All times are GMT -4. The time now is 19:33.