CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

CFX 11 not starting - perl problem (Urgent)

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 9, 2008, 11:49
Default CFX 11 not starting - perl problem (Urgent)
  #1
Luk
Guest
 
Posts: n/a
Hey all, A few days ago I described here my problem with interphase radiation transfer in Ansys 10. Someone adviced me to use CFX 11 which utilizes a beta model of the radiation transport. Since I have no acess to ver. 11 I get to my friends using Ansys 11 (but not very inside CFD) to test it. There is a problem with starting CFX - after instalation, when I try to run cfx5pre.exe the comment appears: can't find file\Glob.pm. It is very strange since that file is present on disc directiories etc. It is a 16Gb pentium quad-core machine windows xp x64. For me it is very urgent to test if the interphase transport works so I would be very grateful for any help!

Lukasz
  Reply With Quote

Old   June 9, 2008, 22:06
Default Re: CFX 11 not starting - perl problem (Urgent)
  #2
Glenn Horrocks
Guest
 
Posts: n/a
Hi,

Start the CFX components from the launcher. That should sort the path out to the executables.

Glenn Horrocks
  Reply With Quote

Old   June 10, 2008, 01:39
Default Re: CFX 11 not starting - perl problem (Urgent)
  #3
Luk
Guest
 
Posts: n/a
Hi, Do You mean not from cfx5.exe? This one are not starting also Tryingo to run from Workbench displays communicate like: CFX-Pre has been terminated.... I must add that the problem seems to be related to Windows x64. In old windows (XP pro) it works but system can see 4 GB of RAM what is unacceptable for me.

Luk
  Reply With Quote

Old   June 10, 2008, 07:11
Default Re: CFX 11 not starting - perl problem (Urgent)
  #4
Glenn Horrocks
Guest
 
Posts: n/a
Hi,

If you are WinXP64 It should have put a CFX icon on the desktop and/or the start menu. Fire up the launcher from that icon.

Glenn
  Reply With Quote

Old   June 10, 2008, 07:14
Default Re: CFX 11 not starting - perl problem (Urgent)
  #5
Luk
Guest
 
Posts: n/a
Belive me I have tried that It gives nothing as also putting the requested glob.pm file in requested directory.
  Reply With Quote

Old   June 10, 2008, 23:31
Default Re: CFX 11 not starting - perl problem (Urgent)
  #6
Glenn Horrocks
Guest
 
Posts: n/a
Hi,

I would uninstall it and reinstall - make sure you install with admin rights. I guess you have already done that. If that fails then I would talk to CFX support.

Glenn Horrocks
  Reply With Quote

Old   June 11, 2008, 02:10
Default Re: CFX 11 not starting - perl problem (Urgent)
  #7
Luk
Guest
 
Posts: n/a
hi, thanks for Your kind help. Installation goes without any problems. The point seems to be about the perl. Searching the net I have found similar communicates among other users of various pearl applications with perl 5.8.0. I have no idea what to do since I am not pearl specialist. The strange thing is that no one else seems to have this problem with CFX. I want to emphasize that the same distribution works fine under XP (not x64).

Luk
  Reply With Quote

Old   June 12, 2008, 09:34
Default Re: CFX 11 not starting - perl problem (Urgent)
  #8
Monteiro
Guest
 
Posts: n/a
Hi!

Are you installing the CFX 64 bits version?

  Reply With Quote

Old   June 12, 2008, 11:00
Default Re: CFX 11 not starting - perl problem (Urgent)
  #9
Luk
Guest
 
Posts: n/a
Well, I must say that I dont know since I am only a guest using software on someons comp, but this is definetely good direction since it works on 32 system (I mean with not x64 windows) and crashes under x64. Can You say how to check it? Do you mean that there are various distributions? This one I can see in front of me is Ansys 11 SP1 but how to check about number of bits?

I would be very grateful for help since working on 4GB is very hard for my problem!!
  Reply With Quote

Old   June 12, 2008, 11:35
Default Re: CFX 11 not starting - perl problem (Urgent)
  #10
Luk
Guest
 
Posts: n/a
And second question specially to You Monteiro (thanks for Your kind help anyway): in my previous tread about multiphase radiation You have said that multiphase radiation is present in Ansys 11 as beta. I can see it in Pre and enable all the opitons but if I try to start to solve any case with enabled radiaiton with multiphase domain(s) the solver stops with the error "Multiphase radiation is not allowed" (or something like this). Do You know if this option realy works or how to switch it on in slover?

Luk
  Reply With Quote

Old   August 17, 2009, 18:05
Default Same Problem
  #11
Member
 
Jules Bell
Join Date: May 2009
Posts: 31
Rep Power: 8
Jules is on a distinguished road
I have the exact same problem as luk. I have a 3D calculation to do which by far exceeds the 4 GB (in fact:3 GB) of RAM available under the 32bit version of windows xp. I've tried it with vista 64 bit and thought it didn't work because it wasn't compatible with vista. However i've also tried installing win xp x64 and CFX 11.0 sp1 onto it, and i get the same problem which seems to be caused by perl, that the program just won't start, and when started from cmd gives out an error message as stated by luk.
I have a 32 bit version of CFX. This doesn't seem to be the issue though, does it?
Can anyone offer help?

Thanks a lot

Jules
Jules is offline   Reply With Quote

Old   August 17, 2009, 18:40
Default
  #12
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 10,646
Rep Power: 84
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
Hi,

CFX11 should work with Vista if you have the service pack installed. There is also a problem with computers with some of the newer CPUs in V11, this is easily resolved by getting a fix from your support office.

If you go to V12 everything should work fine - I strongly suggest you do so. Don't waste your time on superseded software.

Glenn Horrocks
ghorrocks is offline   Reply With Quote

Old   August 18, 2009, 09:31
Default
  #13
Member
 
Paulo Alexandre Costa Rocha
Join Date: Mar 2009
Posts: 71
Rep Power: 8
paulo is on a distinguished road
Quote:
Originally Posted by Monteiro
Hi!

Are you installing the CFX 64 bits version?
Hi Luk,

I also bet on Monteiro's advice. If you changed only the Win version to 64bits, CFX is still compiled to 32 bits OS. I think this is the problem.

You can get the 64 bits version at the same place you have downloaded the 32 bits version (where the support office informed). The license file will work on both.

Best regards,

Paulo Rocha
paulo is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
FSI with cfx starting problem icemaniac178 CFX 1 May 24, 2011 09:46
problem in displaying surfaces in CFX haho CFX 1 July 5, 2009 19:25
Urgent Problem with Hypermesh and CFX Luk CFX 5 March 14, 2008 05:59
CFX 5.5.1 stirred tank and LES problem Nishant CFX 2 September 13, 2002 07:11
CFX 4.4 installation problem Pandu Sattvika CFX 1 December 1, 2001 05:07


All times are GMT -4. The time now is 03:47.