CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   why did it say "Failed to initialize component" (http://www.cfd-online.com/Forums/cfx/26764-why-did-say-failed-initialize-component.html)

abrahamgx December 4, 2008 21:51

why did it say "Failed to initialize component"
 
I'm now dealling with a 2 stages compressor. I first calculate the single passage of the compressor, and the results are very good. But, when I use the multiple passages, e.g. 5 pasaages, the sover can deal that, but the post always say "Failed to initialize component". So I couldn't initiallize in the turbo mode. Could some one help me, I will appreciate his/her help...


CycLone December 5, 2008 00:15

Re: why did it say "Failed to initialize component
 
When Post initializes turbo-components, it uses the region names to find the hub, shroud, inlet, blade, etc. in order to generate the "turbo space" with which it can unwrap the blades, generate the meridional view etc. If you used different naming conventions for the other components, it may not pick up the regions. If you click on the component in the Turbo-Post tree you can view the regions it is using in the details panel. Check that these are the correct regions and add any that may be missing.

-CycLone

abrahamgx December 5, 2008 00:42

Re: why did it say "Failed to initialize component
 
Thank you, CycLone! I will check the regions :)

abrahamgx December 5, 2008 04:11

Re: why did it say "Failed to initialize component
 
Hi CycLone! I have solved the problem under your suggestion! I only changed some specification in the turbo-components, the then it worked so well! Thanks again!


All times are GMT -4. The time now is 08:58.