CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   Interpolation with moving meshes (http://www.cfd-online.com/Forums/cfx/62811-interpolation-moving-meshes.html)

Martijn March 20, 2009 10:31

Interpolation with moving meshes
 
Hi,

I'm trying to simulate the movement of a valve with great displacements. Because of these great displacement I have to change my grid several times during the transient simulation. I start with an initial mesh that deformes until it is as big as the second mesh, then the results of the last run should be interpolated on the new mesh. The problem is that this interpolation is very bad. It seems that CFX-11 uses the old, original, non deformed positions of the mesh nodes to interpolate the results onto the new mesh while it extraplolates the results to the part of the new geometry that is now outside the old geometry.

Is there any way to enhance this interpolation?

Thanks in advance!

Kind regards,

Martijn

mvoss March 20, 2009 11:02

hi,

i am not sure.
There is an option called "include mesh" for the transient results.So the updated nodeparameters are included.
But that sounds to easy for my opinion. ;)

neewbie

ghorrocks March 22, 2009 18:15

Hi,

I reported this exact issue as a bug in CFX many releases ago and was assured by the developers that it had been fixed. But then my work moved on and I never used it again so I have never tested it to see if it really was fixed.

So it may be a bug in CFX which has not been fixed properly yet - keep that in mind as you work on it. If you can show a bug in CFX please report it so it can be fixed.

Glenn Horrocks

Martijn March 23, 2009 08:11

Quote:

Originally Posted by neewbie (Post 210159)
hi,

i am not sure.
There is an option called "include mesh" for the transient results.So the updated nodeparameters are included.
But that sounds to easy for my opinion. ;)

neewbie

Thanks for your reply. Unfortunately this option does not work; .res files are not influenced by this setting (and I think this is option is only valid for CFX <=10). But with testing of this setting I found out that when I use the last .trn file as input for the next run CFX is able to interpolate with the correct result.
The problem with this solution is that I have to write a .trn file every timestep because I do not know how many timesteps my simulation takes.


Does anybody have an idea how to make CFX-11 write only a .trn file when a certain Fortran routine says so?


Glenn Horrocks: I already reported this problem to the CFX support, but do not have an answer yet.

mvoss March 23, 2009 08:40

Quote:

Originally Posted by Martijn (Post 210414)
But with testing of this setting I found out that when I use the last .trn file as input for the next run CFX is able to interpolate with the correct result.

hi,
Thatīs what iīve thought. The option turns on the savingoption for including the mesh in every .trn-file. Thatīs why it worked for you when starting with the last trn.-file.

For the Fortran issue... iīve got no idea.
Sorry.
If you figure it out, please let us know. :)

neewbie

Martijn March 27, 2009 11:20

Solved.
 
I solved the problem.
After some testing I found out that the problem was not caused by the interpolation of CFX. I made a stupid mistake in my Perl script which I used to start the new run. Due to this mistake my initial solution (for the first run) was used every time when starting a new run.
So, interpolating with moving meshes isn't a problem after all...

Glenn and Newbee, thanks for your help.


All times are GMT -4. The time now is 16:29.