CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   question about immersed solid in CFX 12.0 (http://www.cfd-online.com/Forums/cfx/69285-question-about-immersed-solid-cfx-12-0-a.html)

Anny October 18, 2009 21:21

question about immersed solid in CFX 12.0
 
hi,everybody.My question is about immersed solid in ansys CFX 12.0.who has used it?And who knows its accuracy index?I use it to model a supercharger,but its result is far away with the test data. In my model, the inlet boundary is pressure inlet, it is set 0Pa,outlet boundary is 20kPa,it is same as test data,but the massflow rate of the compution is about half of the teat data.I don't konw why.I am suspicious of the CFX model is not suit for gas,it is only suit for liquid.

ghorrocks October 19, 2009 05:55

Quote:

I am suspicious of the CFX model is not suit for gas,it is only suit for liquid
Sounds like rubbish to me. What makes you say that?

The immersed solid feature will not work well if the mesh is not fine enough to resolve the motion and any cracks or gaps which are significant. For instance this means if you are trying to model the leakage in a Roots blower type supercharger you need a very fine mesh to have a few elements in the clearance between the rotors.

Are you sure your mesh is adequate?

Anny October 20, 2009 20:31

I tired a refined mesh in the boundary of the immersed solid, but the result is same as before, not to be better.

Anny October 20, 2009 21:18

http://www.cfd-online.com/Forums/blo...1&d=1256091221
Here is the mesh picture.
http://www.cfd-online.com/Forums/att...1&d=1256091895
Here is the CCL file.

stumpy October 27, 2009 17:01

Immersed Solid does not work with variable density + transient, so in that respect you are correct that it is not suitable for compressible gases in transient runs. Also the default settings can give too much "leakage" through the immersed solid. Under Solver Control try setting the "Momentum Source Scaling Factor" to 50 or 100 and also set the expert parameter "smooth inside ims = t" (required for stability with high Momentum Source Scaling Factors).

Anny November 2, 2009 03:10

stumpy, Thanks for your reply, it's very useful to me, and I tired to do follow your advice. I trid setting the "Momentum Source Scaling Factor" to 50 or 100, 100 is not appropriate, 50 is OK. But where is the expert parameter "smooth inside ims = t"? I can't find it.

stumpy November 3, 2009 18:42

If it's not in the GUI, then you'll have to type it in through the CCL. In the Command Editor you can type:

FLOW: Flow Analysis 1
EXPERT PARAMETERS:
smooth inside ims = t
END
END

I assume your case with the scaling factor set to 100 would have failed without this expert parameter set.

Anny November 3, 2009 20:17

你说对了,你太厉害了,料事如神,我好佩服你啊

Anny November 3, 2009 20:24

English can't express my thanks fully., so I use my mother language Chinese. You are right, when I set to 100, it will tell me there is a error in CFX_solver manager. Thank you very much, you are the saviour to me.

belgacem May 25, 2012 05:57

Hi friend
I am also studying immersed boundary method and and try to simulate a block falling in the water. I am using "immersed solid" then rigid body 6DOF and I let it fall freely but it can't stoped in the bottom where the velocity must be zero. I give a density to the block and i let it fall freely under gravity. Noted that the rigid body is defined as an immersed solid. i have specified a stationary coordinate frame that has its origin at the center of mass of the physical rigid body. Another fixed coordinate frame was specified related to the water at rest.
What can I do to stopped the rigid body in the bottom where the potentiel energy must be zero?

thank you!

yuanmengyuan1989 April 6, 2013 21:57

Quote:

Originally Posted by stumpy (Post 235011)
If it's not in the GUI, then you'll have to type it in through the CCL. In the Command Editor you can type:

FLOW: Flow Analysis 1
EXPERT PARAMETERS:
smooth inside ims = t
END
END

I assume your case with the scaling factor set to 100 would have failed without this expert parameter set.


when i did as you said, i occoured an error :
ERROR #001100000 has occurred in subroutine EPORT_OBSOLETE_PRM. Message: The following unused Expert Solver Parameter was found: || SMOOTH INSIDE IMS | The parameter may be incorrectly spelled.
then i do not now how to do. what's up with it? do you konw? thank you!


All times are GMT -4. The time now is 07:58.