CFD Online Logo CFD Online URL
Home > Forums > CFX

CFX interface error

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   November 18, 2009, 23:04
Default CFX interface error
Senior Member
Join Date: Nov 2009
Posts: 125
Rep Power: 7
mactech001 is on a distinguished road
Hi all,

I encountered an error below:

ERROR #001100279 has occurred in subroutine ErrAction.
All nodes in the domain named insulation are on interfaces. Please modify the mesh to include some non-interface (e.g. internal) nodes.

Attached also is a simple picture of my interfaces. The interfaces are between insulation & coil, and insulation & steel.

Please help.

Attached Images
File Type: jpg cfxInterfaceError.jpg (6.0 KB, 8 views)
Thank you for your kind attention.

Kind regards,
Currently using: ANSYS v13
mactech001 is offline   Reply With Quote

Old   November 19, 2009, 05:37
Super Moderator
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 11,063
Rep Power: 86
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
The error is exactly what it says: You have a domain where all nodes lie on the boundaries (ie walls and interfaces) and it has no interior nodes. This is not allowed. You will have to generate another mesh with at least one layer of nodes in the middle of the domain to have some interior nodes.

Also, in V12 there is a new feature to include thin layers in interfaces, which means you may not need to model the thin layer at all but can include its effect as a thermal resistance on the interface. This can remove the need to generate horrible meshes of very thin bodies. Have a look at the Conjugate heat transfer tutorial (No 16 I think it is) for an example of how to do thin surfaces on interfaces.
ghorrocks is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
POSDAT problem piotka STAR-CD 4 June 12, 2009 08:43
Installation OF1.5-dev ttdtud OpenFOAM Installation 46 May 5, 2009 02:32
Errors running allwmake in OpenFOAM141dev with WM_COMPILE_OPTION%3ddebug unoder OpenFOAM Installation 11 January 30, 2008 21:30
Compiling problems with hello worldC fw407 OpenFOAM Installation 21 January 6, 2008 18:38
Compiling OpenFOAM13 on AMD64 with OpenSUSE 101 silent_missile OpenFOAM Installation 5 August 10, 2007 07:31

All times are GMT -4. The time now is 04:19.