CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   two fluids in CFX-pre (http://www.cfd-online.com/Forums/cfx/71396-two-fluids-cfx-pre.html)

bond December 30, 2009 05:27

two fluids in CFX-pre
 
pls tell me, how can i assign two different fluids in CFX-Pre seperately for two domains. like water and oil. water domain and oil domains are seperate with seperate inlet and outlets......????

Abou ali December 31, 2009 04:08

CFX Beta Features
 
Hi,
The easiest method to use different fluids in different domains is by enabling the Beta features of CFX.
In the CFX-Pre window go to Edit/Options, in the options table select CFX-Pre and activate Enable Beta Features and click Ok.
Now go to the simulation tree and right click on Simulation then disable Constant Domain Physics. Finally you can select the desired fluid for each domain.

pantarei83 January 5, 2010 12:08

I have the same problem, but in my CFX version 10.0 I can't find these commands.
Help me!

stumpy January 6, 2010 15:29

In older versions you need to set the environment variable "CFX5_NO_CONSTANT_PHYSICS = T"

pantarei83 January 7, 2010 04:42

Hi Stumpy,
I'm new to CFX. Can you tell me hot to set the environment variable "CFX5_NO_CONSTANT_PHYSICS = T"?
Thanks a lot

shogologo January 7, 2010 09:26

  1. Click on "START" then Settings then open Control Panel
  2. Click the System icon
  3. Go to the Advanced panel
  4. Click the Environment Variables button
  5. Select the "new" button to create a new environment variable
  6. The value of "VARIABLE NAME " should be
CFX5_NO_CONSTANT_PHYSICS
7. The value of "VARIABLE VALUE" should be

T
Click on "OK" then Restart system

pantarei83 January 7, 2010 11:37

Thank a lot...

makkks July 21, 2011 01:45

HI everyone,

I have a similar problem.
I have two fluids: air and oil
As discussed above I activated Enable Beta Features and disabled Constant Domain Physics.
It changed at first but when I closed and reopened the simulation again, its not working.
I checked options again but it is set to enable beta and disable physics now.
I m not able to get different fluid in different domain.
Plz help

ps: m working on (Ansys 13,windows server2008)

wenwen November 30, 2013 14:16

Quote:

Originally Posted by makkks (Post 316867)
HI everyone,

I have a similar problem.
I have two fluids: air and oil
As discussed above I activated Enable Beta Features and disabled Constant Domain Physics.
It changed at first but when I closed and reopened the simulation again, its not working.
I checked options again but it is set to enable beta and disable physics now.
I m not able to get different fluid in different domain.
Plz help

ps: m working on (Ansys 13,windows server2008)

Not only disable constant domain in edit/option
but also disable it in outline/case option/general


All times are GMT -4. The time now is 07:07.