CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   Restart 2-way FSI with different timestep? (http://www.cfd-online.com/Forums/cfx/71548-restart-2-way-fsi-different-timestep.html)

Lance January 7, 2010 03:45

Restart 2-way FSI with different timestep?
 
Hi,
I've been trying to restart my 2-way FSI simulation with a different timestep without success. There's a section about restarting FSI in the manual, but I can't get the solvers to accept my change in timestep. I've changed the timestep both in the .def file and the .mf file.

So, my questions would be:
1) Is it even possible to restart a FSI simulation with a different timestep?
2) Is there any way to run it with adaptive timesteps instead, i.e. specifying a RMS courant number in CFX and let it work out a suitable timestep?


/Lance

stumpy January 7, 2010 18:11

If you're only changing the timestep, and nothing else, then the def file is the only place it needs changed. You shouldn't have a .mf file (at least not one that you created manually). So change it in the def file, provide the previous res file for CFX, provide the .inp for ANSYS and check "Process Input File" then provide the previous ANSYS.db file.

Lance January 8, 2010 04:35

I did as you said, changed the timestep in def, used previous .res for cfx as initial value, provided the old .inp file, checked proccess ansys input file, and provided the last Ansys.db file.

I changed the timestep from 1e-2 to 5e-3 in .def but still I get the following error:

*** ERROR *** CP = 21.560 TIME= 09:18:06
Time increment for solid field analysis, 1.E-02 is greater than time
increment, 5.E-03 for multifield analysis.

*** ERROR *** CP = 21.560 TIME= 09:18:06
Error during setup - Skipping the remaining MultiField analysis.

I also changed the timestep in .inp with the same result. What am I doing wrong?

u22 October 3, 2012 05:23

Old subject, but now have same problem with changing of timestamp during FSI restart. I'm using ANSYS V14. Does anybody solved this problem??

mali28 October 3, 2012 06:47

Quote:

Originally Posted by u22 (Post 384679)
Old subject, but now have same problem with changing of timestamp during FSI restart. I'm using ANSYS V14. Does anybody solved this problem??

This might be helpful:

http://www.eureka.im/4057.html

u22 October 4, 2012 23:52

Thanks, mali28!
Links helpful, all you need to do is insert the command DELTIM with new timestep in generated mf file. Also correct MFDT command, i guess. And then use it for restart CFX with command line argements "-ansys-restart <previos_run_dir>.ansys/ANSYS.db -ansys-input <corrected mf file>.mf -ansys-input-is-complete". Or via solver GUI...

backside April 10, 2013 21:45

For my calculations (2way FSI), I would like to run a first part with another timestep as for a second part. Till the first break everything works well. Then I change the timestep in the def file, and the mf. (As it was written in the link of mali28)

But I have always following warning message:

+--------------------------------------------------------------------+
| ****** Notice ****** |
| |
| The CFX results that are being used to initialise this |
| simulation were generated at a time value that is inconsistent |
| with the Coupling Initial Time value set in the CFX Input File. |
| Please review results carefully. |
| CFX results time : 4.0000E-02 |
| Coupling Initial Time : 0.0000E+00 |
+--------------------------------------------------------------------+

This is very courious as I tried both, Coupling time : Automatic and Coupling Time: Value ( with the right value).

Has anybody a solution for my problem? Have I done a mistake in modifying the -mf data ( Introducing DELTIM,<VAL>,0,0)..

u22 April 11, 2013 03:48

Are you use previos CFX res file in -def option of cfx5solve? I used cfx5solve for restart in that way:
cfx5solve -def my.res -ccl my.ccl -ansys-restart ./FSI_006.ansys/ANSYS.db -ansys-input ANSYS.mf -ansys-input-is-complete

backside April 11, 2013 09:14

For the moment I'm working with GUI interface. But normally this should do the same. Perhaps a more detailed explanation will help.


I created an input.dat file with a force and a first time step [0.001] for the whole simulation [1s]. Then I'm doing the .def file for the same timestep and a duration for 0.04 (This is equivalent to 40 timesteps). I run this simulation.

Therefore I got the fluid_001.ansys with the ANSYS.mf file as well as fluid_001.res

Now I would like to change the timesteps to 1e-5.

Therefore I modify the .def file (Changing Total time to 1s and timesteps for 10e-5).
Additional I'm introducing DELTIM,1e-5,0,0 in the .mf file.

Then I run the simulation with the def file and in MultFIeld I define Mechanical input the modified .mf file and disable Process ANSYS Input file (This should be the command -ansys-input ANSYS.mf -ansys-input-is-complete )
In the restart I select the .db file (-ansys -restart ./FSI_001.ansys/ANSYS.db )

I think that I'm not really using the .res file as inout as I change the time duration. Is it possible that the change of the total time in the def file creates the problem?I'm doing like 2 calculations in serie. Perhaps therefore the restart doesn't work really.

Quote:

Also correct MFDT command, i guess.
May you explain that more detailed?

u22 April 11, 2013 23:59

in MFDT i used same timestamp as in DELTIM (deltim,1.e-004,1.e-004,1.e-004 and MFDT,1.e-04,1.e-04,1.e-04,OFF). Also, in ansys mech setup i used fixed timestamp (not automatic).

For restart and continuation, you should use res file from previos CFX/FSI run, in CFX setup coupling initial time = automatic. For second run you can edit time step in res file or provide ccl file with changed time step (-ccl option)

backside April 12, 2013 08:50

You wrote that you fixed timestamp in the ansys mech file. Where exactly can I do that?
How can i change the timestep in the .res file?



So after the first simulation I have to change the total time and the timestep in the ANSYS.mf

deltim,<TIMESTEP>,<TIMESTEP>,<TIMESTEP>
MFTI,<Value of total time>,
MFDT,<TIMESTEP>,<TIMESTEP>,<TIMESTEP>,OFF

Than just insert
-def <File>.res -ansys-restart <File>.ansys/ANSYS.db -ansys-input ANSYS.mf -ansys-input-is-complete

u22 April 17, 2013 00:37

Quote:

Originally Posted by backside (Post 420129)
You wrote that you fixed timestamp in the ansys mech file. Where exactly can I do that?
How can i change the timestep in the .res file?

You should edit res file via CFX Solver Manager GUI, main menu "Tools -> Edit CFX Solver file". You can do the same with use of ccl file, read about it in CFX manual

Quote:

So after the first simulation I have to change the total time and the timestep in the ANSYS.mf

deltim,<TIMESTEP>,<TIMESTEP>,<TIMESTEP>
MFTI,<Value of total time>,
MFDT,<TIMESTEP>,<TIMESTEP>,<TIMESTEP>,OFF
Exactly so!

Quote:

Than just insert
-def <File>.res -ansys-restart <File>.ansys/ANSYS.db -ansys-input ANSYS.mf -ansys-input-is-complete
This line is command options for cfx5solve, you can run it via GUI with same options.


All times are GMT -4. The time now is 00:28.