CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   Conjugate Heat Transfer in CFX (http://www.cfd-online.com/Forums/cfx/73983-conjugate-heat-transfer-cfx.html)

Maher Al-Dojayli March 21, 2010 19:28

Conjugate Heat Transfer in CFX
 
Hello All,

I am modeling a simple problem which is conjugate heat transfer in ANSYS CFX. It is a heat sink fin where there is a forced convection.

I run the model and it did converge and the solution made sense. However, it did solve when the mesh of the fin (solid) is coarse, one element per thinkness of the fin. I was able to refine the air medium mesh but as soon as refine the solid mesh ( no matter at what level), ANSYS fails to solve. It starts solving then stops with the following error:

-----------------------------------------------------------
ERROR #001100279 has occurred in subroutine ErrAction.
Message:
SYMASS_CS_ELIM : The solver ran out of temporary space while building a linked list for a domain.


Details of error:-
----------------
Error detected by routine POPDIR
CRESLT = ILEG
-----------------------------------------------------------

I have read some threads about this matter. Nothing really helped.
I put it as Double Precision
I put the memory allocation factor as 1.5

Nothing works. I do not think they matter since the memory was enough for the refine mesh of the air medium which much more than the solid.

Any help in this regard is very much appreciated

Maher

Maher Al-Dojayli March 21, 2010 19:50

Conjugate Heat Transfer in CFX
 
Dear all,

Never mind of the blog. I have solved it.

It was the topology estimate factor as indicated in the error file. I have changed it to a factor of 1.2. This can be done from the CFX-Solver Expert Control Parameters.

Thank you all anyways

Maher

Jade M August 6, 2010 13:24

Please see below some more detailed information from ANSYS Tech Support.

A change in the CFX solver from V 11.0 to V 12.0 has caused CFX to underestimate memory for certain types of problems. Memory usage almost always scales with the number of elements in a problem. In Pre, in the Outline, under Simulation, Flow Analysis 1 and Solver, right click on Expert Parameters and click Edit. Click on tab Convergence Control and, under Memory Control, check topology estimate factor and set the value greater than 1.0. This parameter is a multiplier that scales the memory allocated for topology. Recommended values are 1.2 to 1.4. The memory allocation depends on several factors, which are mesh size, physics, number of nodes at mesh interfaces or periodic planes, and partitioning or complexity of the geometry. Failure corresponds with the calculation where the first memory overrun occurs.

Maher Al-Dojayli August 6, 2010 17:23

Thank you Jade!

Yes, that's what I did back then. It does suggest doing so. However, I did not know the reason behind it. Now, I know.

Thank you again for the clarification

Maher

Jade M August 6, 2010 17:25

You're most welcome, Maher!

I like spreading the knowledge, but also documenting these sorts of things. I have my own "best practices" and random notes but this'll be a great resource if I ever lose or don't have access to them.

Take care!

bubupo November 1, 2011 22:06

I have find the option under Solver , right click then add expert parameters. After setting up, it worked.


All times are GMT -4. The time now is 11:16.